CVE-2020-15192 Memory leak in Tensorflow
An attacker can cause a memory leak in TensorFlow by passing invalid string lists to dlpack.to_dlpack, potentially leading to resource exhaustion.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15192?
CVE-2020-15192 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 25 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Tensorflow before versions 2.2.1 and 2.3.1, if a user passes a list of strings to `dlpack.to_dlpack` there is a memory leak following an expected validation failure. The issue occurs because the `status` argument during validation failures is not properly checked. Since each of the above methods can return an error status, the `status` value must be checked before continuing. The issue is patched in commit 22e07fb204386768e5bcbea563641ea11f96ceb8 and is released in TensorFlow versions 2.2.1, or 2.3.1.
Weakness: CWE-20
Which versions are affected by CVE-2020-15192?
16 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow Bitnami | From 2.2.0 | 2.2.1, 2.3.1 |
tensorflow PyPI | All versions | 2.2.1, 2.3.1 |
tensorflow PyPI | From 2.2.0 | 2.2.1 |
tensorflow PyPI | From 2.2.0 | 2.2.1 |
tensorflow PyPI | From 2.3.0 | 2.3.1 |
tensorflow PyPI | From 2.3.0 | 2.3.1 |
10 more packages
tensorflow-cpu PyPI | All versions | 2.2.1, 2.3.1 |
tensorflow-cpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-cpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-cpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-cpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-gpu PyPI | All versions | 2.2.1, 2.3.1 |
tensorflow-gpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-gpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-gpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-gpu PyPI | From 2.3.0 | 2.3.1 |
Products include Google Tensorflow, Opensuse Leap.
How do I fix CVE-2020-15192?
Upgrade tensorflow to a fixed version for your release line: 2.2.1 or 2.3.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-15192 being exploited?
There is no known exploitation of CVE-2020-15192 in the wild and no public exploit code.
Other vulnerabilities in Google Tensorflow
- CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
- CVE-2021-37678 Arbitrary code execution due to YAML deserialization
- CVE-2021-35958 Path traversal in n/a
- CVE-2020-15202 Integer truncation in Shard API usage
Sources
Also known as BIT-tensorflow-2020-15192, GHSA-8fxw-76px-3rxv, PYSEC-2020-115, PYSEC-2020-272, PYSEC-2020-307.