CVE-2020-15194 Denial of Service in Tensorflow
Attackers can cause denial of service in TensorFlow serving installations by passing invalid arguments to SparseFillEmptyRowsGrad, triggering an assertion failure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15194?
CVE-2020-15194 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 25 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, the `SparseFillEmptyRowsGrad` implementation has incomplete validation of the shapes of its arguments. Although `reverse_index_map_t` and `grad_values_t` are accessed in a similar pattern, only `reverse_index_map_t` is validated to be of proper shape. Hence, malicious users can pass a bad `grad_values_t` to trigger an assertion failure in `vec`, causing denial of service in serving installations. The issue is patched in commit 390611e0d45c5793c7066110af37c8514e6a6c54, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1."
Which versions are affected by CVE-2020-15194?
34 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow Bitnami | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow PyPI | All versions | 1.15.4 |
tensorflow PyPI | All versions | 1.15.4 |
tensorflow PyPI | From 2.0.0 | 2.0.3 |
tensorflow PyPI | From 2.0.0 | 2.0.3 |
28 more packages
tensorflow PyPI | From 2.1.0 | 2.1.2 |
tensorflow PyPI | From 2.1.0 | 2.1.2 |
tensorflow PyPI | From 2.2.0 | 2.2.1 |
tensorflow PyPI | From 2.2.0 | 2.2.1 |
tensorflow PyPI | From 2.3.0 | 2.3.1 |
tensorflow PyPI | From 2.3.0 | 2.3.1 |
tensorflow-cpu PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow-cpu PyPI | All versions | 1.15.4 |
tensorflow-cpu PyPI | All versions | 1.15.4 |
tensorflow-cpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-cpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-cpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-cpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-cpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-cpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-cpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-cpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-gpu PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow-gpu PyPI | All versions | 1.15.4 |
tensorflow-gpu PyPI | All versions | 1.15.4 |
tensorflow-gpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-gpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-gpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-gpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-gpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-gpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-gpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-gpu PyPI | From 2.3.0 | 2.3.1 |
Products include Google Tensorflow, Opensuse Leap.
How do I fix CVE-2020-15194?
Upgrade tensorflow to a fixed version for your release line: 1.15.4, 2.0.3, 2.1.2 or 2.2.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-15194 being exploited?
There is no known exploitation of CVE-2020-15194 in the wild and no public exploit code.
Other vulnerabilities in Google Tensorflow
- CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
- CVE-2021-37678 Arbitrary code execution due to YAML deserialization
- CVE-2021-35958 Path traversal in n/a
- CVE-2020-15202 Integer truncation in Shard API usage
Sources
Also known as BIT-tensorflow-2020-15194, GHSA-9mqp-7v2h-2382, PYSEC-2020-117, PYSEC-2020-274, PYSEC-2020-309.