CVE-2020-15195 Heap buffer overflow in Tensorflow

High 8.5 Published Updated

Heap buffer overflow in TensorFlow's SparseFillEmptyRowsGrad allows attackers to cause crashes or execute arbitrary code via crafted inputs.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-15195?

CVE-2020-15195 is a high-severity memory corruption vulnerability in Google Tensorflow, published on 25 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, the implementation of `SparseFillEmptyRowsGrad` uses a double indexing pattern. It is possible for `reverse_index_map(i)` to be an index outside of bounds of `grad_values`, thus resulting in a heap buffer overflow. The issue is patched in commit 390611e0d45c5793c7066110af37c8514e6a6c54, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

Weakness: CWE-122, CWE-787, CWE-119

Which versions are affected by CVE-2020-15195?

34 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 2 products.

PackageAffectedFixed in
tensorflow BitnamiAll versions1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
tensorflow PyPIAll versions1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
tensorflow PyPIAll versions1.15.4
tensorflow PyPIAll versions1.15.4
tensorflow PyPIFrom 2.0.02.0.3
tensorflow PyPIFrom 2.0.02.0.3
28 more packages
tensorflow PyPIFrom 2.1.02.1.2
tensorflow PyPIFrom 2.1.02.1.2
tensorflow PyPIFrom 2.2.02.2.1
tensorflow PyPIFrom 2.2.02.2.1
tensorflow PyPIFrom 2.3.02.3.1
tensorflow PyPIFrom 2.3.02.3.1
tensorflow-cpu PyPIAll versions1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
tensorflow-cpu PyPIAll versions1.15.4
tensorflow-cpu PyPIAll versions1.15.4
tensorflow-cpu PyPIFrom 2.0.02.0.3
tensorflow-cpu PyPIFrom 2.0.02.0.3
tensorflow-cpu PyPIFrom 2.1.02.1.2
tensorflow-cpu PyPIFrom 2.1.02.1.2
tensorflow-cpu PyPIFrom 2.2.02.2.1
tensorflow-cpu PyPIFrom 2.2.02.2.1
tensorflow-cpu PyPIFrom 2.3.02.3.1
tensorflow-cpu PyPIFrom 2.3.02.3.1
tensorflow-gpu PyPIAll versions1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
tensorflow-gpu PyPIAll versions1.15.4
tensorflow-gpu PyPIAll versions1.15.4
tensorflow-gpu PyPIFrom 2.0.02.0.3
tensorflow-gpu PyPIFrom 2.0.02.0.3
tensorflow-gpu PyPIFrom 2.1.02.1.2
tensorflow-gpu PyPIFrom 2.1.02.1.2
tensorflow-gpu PyPIFrom 2.2.02.2.1
tensorflow-gpu PyPIFrom 2.2.02.2.1
tensorflow-gpu PyPIFrom 2.3.02.3.1
tensorflow-gpu PyPIFrom 2.3.02.3.1

Products include Google Tensorflow, Opensuse Leap.

How do I fix CVE-2020-15195?

Upgrade tensorflow to a fixed version for your release line: 1.15.4, 2.0.3, 2.1.2 or 2.2.1.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2020-15195 being exploited?

There is no known exploitation of CVE-2020-15195 in the wild and no public exploit code.

All Google Tensorflow vulnerabilities

Sources

Also known as BIT-tensorflow-2020-15195, GHSA-63xm-rx5p-xvqr, PYSEC-2020-118, PYSEC-2020-275, PYSEC-2020-310.

Is CVE-2020-15195 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free