# CVE-2020-15199: Denial of Service in Tensorflow

> An attacker can cause a denial of service by providing invalid input to the RaggedCountSparseOutput operation, triggering a crash.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-tensorflow-2020-15199, GHSA-x5cp-9pcf-pp3h, PYSEC-2020-122, PYSEC-2020-279, PYSEC-2020-314

## What is CVE-2020-15199?

CVE-2020-15199 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 25 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Tensorflow before version 2.3.1, the `RaggedCountSparseOutput` does not validate that the input arguments form a valid ragged tensor. In particular, there is no validation that the `splits` tensor has the minimum required number of elements. Code uses this quantity to initialize a different data structure. Since `BatchedMap` is equivalent to a vector, it needs to have at least one element to not be `nullptr`. If user passes a `splits` tensor that is empty or has exactly one element, we get a `SIGABRT` signal raised by the operating system. The issue is patched in commit 3cbb917b4714766030b28eba9fb41bb97ce9ee02 and is released in TensorFlow version 2.3.1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-15199?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | Bitnami | From 2.3.0 | 2.3.1 |
| `tensorflow` | PyPI | All versions | 2.3.1 |
| `tensorflow` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow-cpu` | PyPI | All versions | 2.3.1 |
| `tensorflow-cpu` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow-cpu` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow-gpu` | PyPI | All versions | 2.3.1 |
| `tensorflow-gpu` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow-gpu` | PyPI | From 2.3.0 | 2.3.1 |

Products: Google Tensorflow.

## How do I fix CVE-2020-15199?

Upgrade tensorflow to 2.3.1 or later.

## Is CVE-2020-15199 being exploited?

There is no known exploitation of CVE-2020-15199 in the wild and no public exploit code.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15199 and fix it if it is affected.

What it is: CVE-2020-15199 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 25 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15199 in the wild and no public exploit code.

Affected packages and fixed versions:
- tensorflow (Bitnami): affected from 2.3.0; fixed in 2.3.1
- tensorflow (PyPI): affected all versions; fixed in 2.3.1
- tensorflow (PyPI): affected from 2.3.0; fixed in 2.3.1
- tensorflow (PyPI): affected from 2.3.0; fixed in 2.3.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.3.1
- tensorflow-cpu (PyPI): affected from 2.3.0; fixed in 2.3.1
- tensorflow-cpu (PyPI): affected from 2.3.0; fixed in 2.3.1
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.3.1
- tensorflow-gpu (PyPI): affected from 2.3.0; fixed in 2.3.1
- tensorflow-gpu (PyPI): affected from 2.3.0; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15199/ (Markdown: https://insights.sbomify.com/CVE-2020-15199/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15199
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15199
- OSV: https://osv.dev/vulnerability/CVE-2020-15199

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15199/
Summaries are generated and may contain mistakes; the official description above is the record.
