# CVE-2020-15203: Denial of Service in Tensorflow

> A format string vulnerability in TensorFlow's tf.strings.as_string allows attackers to cause a segmentation fault and denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-tensorflow-2020-15203, GHSA-xmq7-7fxm-rr79, PYSEC-2020-126, PYSEC-2020-283, PYSEC-2020-318

## What is CVE-2020-15203?

CVE-2020-15203 is a high-severity denial of service vulnerability in Google Tensorflow, published on 25 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, by controlling the `fill` argument of tf.strings.as_string, a malicious attacker is able to trigger a format string vulnerability due to the way the internal format use in a `printf` call is constructed. This may result in segmentation fault. The issue is patched in commit 33be22c65d86256e6826666662e40dbdfe70ee83, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

Weakness: CWE-134 (Use of Externally-Controlled Format String), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-15203?

34 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | Bitnami | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
| `tensorflow` | PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
| `tensorflow` | PyPI | All versions | 1.15.4 |
| `tensorflow` | PyPI | All versions | 1.15.4 |
| `tensorflow` | PyPI | From 2.0.0 | 2.0.3 |
| `tensorflow` | PyPI | From 2.0.0 | 2.0.3 |
| `tensorflow` | PyPI | From 2.1.0 | 2.1.2 |
| `tensorflow` | PyPI | From 2.1.0 | 2.1.2 |
| `tensorflow` | PyPI | From 2.2.0 | 2.2.1 |
| `tensorflow` | PyPI | From 2.2.0 | 2.2.1 |
| `tensorflow` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow-cpu` | PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
| `tensorflow-cpu` | PyPI | All versions | 1.15.4 |
| `tensorflow-cpu` | PyPI | All versions | 1.15.4 |
| `tensorflow-cpu` | PyPI | From 2.0.0 | 2.0.3 |
| `tensorflow-cpu` | PyPI | From 2.0.0 | 2.0.3 |
| `tensorflow-cpu` | PyPI | From 2.1.0 | 2.1.2 |
| `tensorflow-cpu` | PyPI | From 2.1.0 | 2.1.2 |
| `tensorflow-cpu` | PyPI | From 2.2.0 | 2.2.1 |
| `tensorflow-cpu` | PyPI | From 2.2.0 | 2.2.1 |
| `tensorflow-cpu` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow-cpu` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow-gpu` | PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
| `tensorflow-gpu` | PyPI | All versions | 1.15.4 |
| `tensorflow-gpu` | PyPI | All versions | 1.15.4 |
| `tensorflow-gpu` | PyPI | From 2.0.0 | 2.0.3 |
| `tensorflow-gpu` | PyPI | From 2.0.0 | 2.0.3 |
| `tensorflow-gpu` | PyPI | From 2.1.0 | 2.1.2 |
| `tensorflow-gpu` | PyPI | From 2.1.0 | 2.1.2 |
| `tensorflow-gpu` | PyPI | From 2.2.0 | 2.2.1 |
| `tensorflow-gpu` | PyPI | From 2.2.0 | 2.2.1 |
| `tensorflow-gpu` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow-gpu` | PyPI | From 2.3.0 | 2.3.1 |

Products: Google Tensorflow, Opensuse Leap.

## How do I fix CVE-2020-15203?

Upgrade tensorflow to a fixed version for your release line: 1.15.4, 2.0.3, 2.1.2 or 2.2.1.

## Is CVE-2020-15203 being exploited?

There is no known exploitation of CVE-2020-15203 in the wild and no public exploit code.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15203 and fix it if it is affected.

What it is: CVE-2020-15203 is a high-severity denial of service vulnerability in Google Tensorflow, published on 25 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15203 in the wild and no public exploit code.

Affected packages and fixed versions:
- tensorflow (Bitnami): affected all versions; fixed in 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
- tensorflow (PyPI): affected all versions; fixed in 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
- tensorflow (PyPI): affected all versions; fixed in 1.15.4
- tensorflow (PyPI): affected all versions; fixed in 1.15.4
- tensorflow (PyPI): affected from 2.0.0; fixed in 2.0.3
- tensorflow (PyPI): affected from 2.0.0; fixed in 2.0.3
- tensorflow (PyPI): affected from 2.1.0; fixed in 2.1.2
- tensorflow (PyPI): affected from 2.1.0; fixed in 2.1.2
- tensorflow (PyPI): affected from 2.2.0; fixed in 2.2.1
- tensorflow (PyPI): affected from 2.2.0; fixed in 2.2.1
- tensorflow (PyPI): affected from 2.3.0; fixed in 2.3.1
- tensorflow (PyPI): affected from 2.3.0; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15203/ (Markdown: https://insights.sbomify.com/CVE-2020-15203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15203
- OSV: https://osv.dev/vulnerability/CVE-2020-15203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15203/
Summaries are generated and may contain mistakes; the official description above is the record.
