CVE-2020-15204 Segfault in Tensorflow

Medium 5.3 Published Updated

An attacker can cause a segmentation fault and denial of service in TensorFlow by triggering a null pointer dereference in eager mode via specific raw operations.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-15204?

CVE-2020-15204 is a medium-severity vulnerability in Google Tensorflow, published on 25 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In eager mode, TensorFlow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1 does not set the session state. Hence, calling `tf.raw_ops.GetSessionHandle` or `tf.raw_ops.GetSessionHandleV2` results in a null pointer dereference In linked snippet, in eager mode, `ctx->session_state()` returns `nullptr`. Since code immediately dereferences this, we get a segmentation fault. The issue is patched in commit 9a133d73ae4b4664d22bd1aa6d654fec13c52ee1, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

Weakness: CWE-476

Which versions are affected by CVE-2020-15204?

34 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 2 products.

PackageAffectedFixed in
tensorflow BitnamiAll versions1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
tensorflow PyPIAll versions1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
tensorflow PyPIAll versions1.15.4
tensorflow PyPIAll versions1.15.4
tensorflow PyPIFrom 2.0.02.0.3
tensorflow PyPIFrom 2.0.02.0.3
28 more packages
tensorflow PyPIFrom 2.1.02.1.2
tensorflow PyPIFrom 2.1.02.1.2
tensorflow PyPIFrom 2.2.02.2.1
tensorflow PyPIFrom 2.2.02.2.1
tensorflow PyPIFrom 2.3.02.3.1
tensorflow PyPIFrom 2.3.02.3.1
tensorflow-cpu PyPIAll versions1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
tensorflow-cpu PyPIAll versions1.15.4
tensorflow-cpu PyPIAll versions1.15.4
tensorflow-cpu PyPIFrom 2.0.02.0.3
tensorflow-cpu PyPIFrom 2.0.02.0.3
tensorflow-cpu PyPIFrom 2.1.02.1.2
tensorflow-cpu PyPIFrom 2.1.02.1.2
tensorflow-cpu PyPIFrom 2.2.02.2.1
tensorflow-cpu PyPIFrom 2.2.02.2.1
tensorflow-cpu PyPIFrom 2.3.02.3.1
tensorflow-cpu PyPIFrom 2.3.02.3.1
tensorflow-gpu PyPIAll versions1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
tensorflow-gpu PyPIAll versions1.15.4
tensorflow-gpu PyPIAll versions1.15.4
tensorflow-gpu PyPIFrom 2.0.02.0.3
tensorflow-gpu PyPIFrom 2.0.02.0.3
tensorflow-gpu PyPIFrom 2.1.02.1.2
tensorflow-gpu PyPIFrom 2.1.02.1.2
tensorflow-gpu PyPIFrom 2.2.02.2.1
tensorflow-gpu PyPIFrom 2.2.02.2.1
tensorflow-gpu PyPIFrom 2.3.02.3.1
tensorflow-gpu PyPIFrom 2.3.02.3.1

Products include Google Tensorflow, Opensuse Leap.

How do I fix CVE-2020-15204?

Upgrade tensorflow to a fixed version for your release line: 1.15.4, 2.0.3, 2.1.2 or 2.2.1.

Is CVE-2020-15204 being exploited?

There is no known exploitation of CVE-2020-15204 in the wild and no public exploit code.

All Google Tensorflow vulnerabilities

Sources

Also known as BIT-tensorflow-2020-15204, GHSA-q8gv-q7wr-9jf8, PYSEC-2020-127, PYSEC-2020-284, PYSEC-2020-319.

Is CVE-2020-15204 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free