CVE-2020-15207 Segfault and data corruption in tensorflow-lite
Attackers can trigger out-of-bounds memory access in TensorFlow Lite via negative indices, causing crashes or data corruption.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15207?
CVE-2020-15207 is a high-severity memory corruption vulnerability in Google Tensorflow, published on 25 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, to mimic Python's indexing with negative values, TFLite uses `ResolveAxis` to convert negative values to positive indices. However, the only check that the converted index is now valid is only present in debug builds. If the `DCHECK` does not trigger, then code execution moves ahead with a negative index. This, in turn, results in accessing data out of bounds which results in segfaults and/or data corruption. The issue is patched in commit 2d88f470dea2671b430884260f3626b1fe99830a, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.
Which versions are affected by CVE-2020-15207?
34 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow Bitnami | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow PyPI | All versions | 1.15.4 |
tensorflow PyPI | All versions | 1.15.4 |
tensorflow PyPI | From 2.0.0 | 2.0.3 |
tensorflow PyPI | From 2.0.0 | 2.0.3 |
28 more packages
tensorflow PyPI | From 2.1.0 | 2.1.2 |
tensorflow PyPI | From 2.1.0 | 2.1.2 |
tensorflow PyPI | From 2.2.0 | 2.2.1 |
tensorflow PyPI | From 2.2.0 | 2.2.1 |
tensorflow PyPI | From 2.3.0 | 2.3.1 |
tensorflow PyPI | From 2.3.0 | 2.3.1 |
tensorflow-cpu PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow-cpu PyPI | All versions | 1.15.4 |
tensorflow-cpu PyPI | All versions | 1.15.4 |
tensorflow-cpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-cpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-cpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-cpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-cpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-cpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-cpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-cpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-gpu PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow-gpu PyPI | All versions | 1.15.4 |
tensorflow-gpu PyPI | All versions | 1.15.4 |
tensorflow-gpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-gpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-gpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-gpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-gpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-gpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-gpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-gpu PyPI | From 2.3.0 | 2.3.1 |
Products include Google Tensorflow, Opensuse Leap.
How do I fix CVE-2020-15207?
Upgrade tensorflow to a fixed version for your release line: 1.15.4, 2.0.3, 2.1.2 or 2.2.1.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2020-15207 being exploited?
There is no known exploitation of CVE-2020-15207 in the wild and no public exploit code.
Other vulnerabilities in Google Tensorflow
- CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
- CVE-2021-37678 Arbitrary code execution due to YAML deserialization
- CVE-2021-35958 Path traversal in n/a
- CVE-2020-15202 Integer truncation in Shard API usage
Sources
Also known as BIT-tensorflow-2020-15207, GHSA-q4qf-3fc6-8x34, PYSEC-2020-130, PYSEC-2020-287, PYSEC-2020-322.