CVE-2020-15208 Data corruption in tensorflow-lite
Attackers can trigger out-of-bounds reads and writes in TensorFlow Lite by crafting tensors with mismatched dimensions, potentially leading to code execution or crashes.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15208?
CVE-2020-15208 is a high-severity memory corruption vulnerability in Google Tensorflow, published on 25 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, when determining the common dimension size of two tensors, TFLite uses a `DCHECK` which is no-op outside of debug compilation modes. Since the function always returns the dimension of the first tensor, malicious attackers can craft cases where this is larger than that of the second tensor. In turn, this would result in reads/writes outside of bounds since the interpreter will wrongly assume that there is enough data in both tensors. The issue is patched in commit 8ee24e7949a203d234489f9da2c5bf45a7d5157d, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.
Which versions are affected by CVE-2020-15208?
34 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow Bitnami | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow PyPI | All versions | 1.15.4 |
tensorflow PyPI | All versions | 1.15.4 |
tensorflow PyPI | From 2.0.0 | 2.0.3 |
tensorflow PyPI | From 2.0.0 | 2.0.3 |
28 more packages
tensorflow PyPI | From 2.1.0 | 2.1.2 |
tensorflow PyPI | From 2.1.0 | 2.1.2 |
tensorflow PyPI | From 2.2.0 | 2.2.1 |
tensorflow PyPI | From 2.2.0 | 2.2.1 |
tensorflow PyPI | From 2.3.0 | 2.3.1 |
tensorflow PyPI | From 2.3.0 | 2.3.1 |
tensorflow-cpu PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow-cpu PyPI | All versions | 1.15.4 |
tensorflow-cpu PyPI | All versions | 1.15.4 |
tensorflow-cpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-cpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-cpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-cpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-cpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-cpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-cpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-cpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-gpu PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow-gpu PyPI | All versions | 1.15.4 |
tensorflow-gpu PyPI | All versions | 1.15.4 |
tensorflow-gpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-gpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-gpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-gpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-gpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-gpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-gpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-gpu PyPI | From 2.3.0 | 2.3.1 |
Products include Google Tensorflow, Opensuse Leap.
How do I fix CVE-2020-15208?
Upgrade tensorflow to a fixed version for your release line: 1.15.4, 2.0.3, 2.1.2 or 2.2.1.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2020-15208 being exploited?
There is no known exploitation of CVE-2020-15208 in the wild and no public exploit code.
Other vulnerabilities in Google Tensorflow
- CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
- CVE-2021-37678 Arbitrary code execution due to YAML deserialization
- CVE-2021-35958 Path traversal in n/a
- CVE-2020-15202 Integer truncation in Shard API usage
Sources
Also known as BIT-tensorflow-2020-15208, GHSA-mxjj-953w-2c2v, PYSEC-2020-131, PYSEC-2020-288, PYSEC-2020-323.