CVE-2020-15211 Out of bounds access in tensorflow-lite
An out-of-bounds access vulnerability in TensorFlow Lite allows attackers to read or write heap memory via crafted models, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15211?
CVE-2020-15211 is a medium-severity memory corruption vulnerability in Google Tensorflow, published on 25 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In TensorFlow Lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, saved models in the flatbuffer format use a double indexing scheme: a model has a set of subgraphs, each subgraph has a set of operators and each operator has a set of input/output tensors. The flatbuffer format uses indices for the tensors, indexing into an array of tensors that is owned by the subgraph. This results in a pattern of double array indexing when trying to get the data of each tensor. However, some operators can have some tensors be optional. To handle this scenario, the flatbuffer model uses a negative `-1` value as index for these tensors. This results in special casing during validation at model loading time. Unfortunately, this means that the `-1` index is a valid tensor index for any operator, including those that don't expect optional inputs and including for output tensors. Thus, this allows writing and reading from outside the bounds of heap allocated arrays, although only at a specific offset from the start of these arrays. This results in both read and write gadgets, albeit very limited in scope. The issue is patched in several commits (46d5b0852, 00302787b7, e11f5558, cd31fd0ce, 1970c21, and fff2c83), and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1. A potential workaround would be to add a custom `Verifier` to the model loading code to ensure that only operators which accept optional inputs use the `-1` special value and only for the tensors that they expect to be optional. Since this allow-list type approach is erro-prone, we advise upgrading to the patched code.
Which versions are affected by CVE-2020-15211?
34 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow Bitnami | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow PyPI | All versions | 1.15.4 |
tensorflow PyPI | All versions | 1.15.4 |
tensorflow PyPI | From 2.0.0 | 2.0.3 |
tensorflow PyPI | From 2.0.0 | 2.0.3 |
28 more packages
tensorflow PyPI | From 2.1.0 | 2.1.2 |
tensorflow PyPI | From 2.1.0 | 2.1.2 |
tensorflow PyPI | From 2.2.0 | 2.2.1 |
tensorflow PyPI | From 2.2.0 | 2.2.1 |
tensorflow PyPI | From 2.3.0 | 2.3.1 |
tensorflow PyPI | From 2.3.0 | 2.3.1 |
tensorflow-cpu PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow-cpu PyPI | All versions | 1.15.4 |
tensorflow-cpu PyPI | All versions | 1.15.4 |
tensorflow-cpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-cpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-cpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-cpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-cpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-cpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-cpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-cpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-gpu PyPI | All versions | 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1 |
tensorflow-gpu PyPI | All versions | 1.15.4 |
tensorflow-gpu PyPI | All versions | 1.15.4 |
tensorflow-gpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-gpu PyPI | From 2.0.0 | 2.0.3 |
tensorflow-gpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-gpu PyPI | From 2.1.0 | 2.1.2 |
tensorflow-gpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-gpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-gpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-gpu PyPI | From 2.3.0 | 2.3.1 |
Products include Google Tensorflow, Opensuse Leap.
How do I fix CVE-2020-15211?
Upgrade tensorflow to a fixed version for your release line: 1.15.4, 2.0.3, 2.1.2 or 2.2.1.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2020-15211 being exploited?
There is no known exploitation of CVE-2020-15211 in the wild and no public exploit code.
Other vulnerabilities in Google Tensorflow
- CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
- CVE-2021-37678 Arbitrary code execution due to YAML deserialization
- CVE-2021-35958 Path traversal in n/a
- CVE-2020-15202 Integer truncation in Shard API usage
Sources
Also known as BIT-tensorflow-2020-15211, GHSA-cvpc-8phh-8f45, PYSEC-2020-134, PYSEC-2020-291, PYSEC-2020-326.