CVE-2020-15212 Out of bounds access in tensorflow-lite

High 8.1 Published Updated

Attackers can trigger out-of-bounds writes in TensorFlow Lite via crafted segment IDs, potentially leading to code execution or crashes.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-15212?

CVE-2020-15212 is a high-severity memory corruption vulnerability in Google Tensorflow, published on 25 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In TensorFlow Lite before versions 2.2.1 and 2.3.1, models using segment sum can trigger writes outside of bounds of heap allocated buffers by inserting negative elements in the segment ids tensor. Users having access to `segment_ids_data` can alter `output_index` and then write to outside of `output_data` buffer. This might result in a segmentation fault but it can also be used to further corrupt the memory and can be chained with other vulnerabilities to create more advanced exploits. The issue is patched in commit 204945b19e44b57906c9344c0d00120eeeae178a and is released in TensorFlow versions 2.2.1, or 2.3.1. A potential workaround would be to add a custom `Verifier` to the model loading code to ensure that the segment ids are all positive, although this only handles the case when the segment ids are stored statically in the model. A similar validation could be done if the segment ids are generated at runtime between inference steps. If the segment ids are generated as outputs of a tensor during inference steps, then there are no possible workaround and users are advised to upgrade to patched code.

Weakness: CWE-787

Which versions are affected by CVE-2020-15212?

16 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow BitnamiFrom 2.2.02.2.1, 2.3.1
tensorflow PyPIFrom 2.2.02.2.1
tensorflow PyPIFrom 2.2.02.2.1
tensorflow PyPIFrom 2.3.02.3.1, 2.2.1
tensorflow PyPIFrom 2.3.02.3.1
tensorflow PyPIFrom 2.3.02.3.1
10 more packages
tensorflow-cpu PyPIFrom 2.2.02.2.1
tensorflow-cpu PyPIFrom 2.2.02.2.1
tensorflow-cpu PyPIFrom 2.3.02.3.1, 2.2.1
tensorflow-cpu PyPIFrom 2.3.02.3.1
tensorflow-cpu PyPIFrom 2.3.02.3.1
tensorflow-gpu PyPIFrom 2.2.02.2.1
tensorflow-gpu PyPIFrom 2.2.02.2.1
tensorflow-gpu PyPIFrom 2.3.02.3.1, 2.2.1
tensorflow-gpu PyPIFrom 2.3.02.3.1
tensorflow-gpu PyPIFrom 2.3.02.3.1

Products include Google Tensorflow.

How do I fix CVE-2020-15212?

Upgrade tensorflow to a fixed version for your release line: 2.2.1 or 2.3.1.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2020-15212 being exploited?

There is no known exploitation of CVE-2020-15212 in the wild and no public exploit code.

All Google Tensorflow vulnerabilities

Sources

Also known as BIT-tensorflow-2020-15212, GHSA-hx2x-85gr-wrpq, PYSEC-2020-135, PYSEC-2020-292, PYSEC-2020-327.

Is CVE-2020-15212 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free