CVE-2020-15213 Denial of service in tensorflow-lite
Attackers can cause denial of service in TensorFlow Lite by triggering excessive memory allocation via crafted segment sum models.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15213?
CVE-2020-15213 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 25 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In TensorFlow Lite before versions 2.2.1 and 2.3.1, models using segment sum can trigger a denial of service by causing an out of memory allocation in the implementation of segment sum. Since code uses the last element of the tensor holding them to determine the dimensionality of output tensor, attackers can use a very large value to trigger a large allocation. The issue is patched in commit 204945b19e44b57906c9344c0d00120eeeae178a and is released in TensorFlow versions 2.2.1, or 2.3.1. A potential workaround would be to add a custom `Verifier` to limit the maximum value in the segment ids tensor. This only handles the case when the segment ids are stored statically in the model, but a similar validation could be done if the segment ids are generated at runtime, between inference steps. However, if the segment ids are generated as outputs of a tensor during inference steps, then there are no possible workaround and users are advised to upgrade to patched code.
Which versions are affected by CVE-2020-15213?
16 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow Bitnami | From 2.2.0 | 2.2.1, 2.3.1 |
tensorflow PyPI | From 2.2.0 | 2.2.1, 2.3.1 |
tensorflow PyPI | From 2.2.0 | 2.2.1 |
tensorflow PyPI | From 2.2.0 | 2.2.1 |
tensorflow PyPI | From 2.3.0 | 2.3.1 |
tensorflow PyPI | From 2.3.0 | 2.3.1 |
10 more packages
tensorflow-cpu PyPI | From 2.2.0 | 2.2.1, 2.3.1 |
tensorflow-cpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-cpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-cpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-cpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-gpu PyPI | From 2.2.0 | 2.2.1, 2.3.1 |
tensorflow-gpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-gpu PyPI | From 2.2.0 | 2.2.1 |
tensorflow-gpu PyPI | From 2.3.0 | 2.3.1 |
tensorflow-gpu PyPI | From 2.3.0 | 2.3.1 |
Products include Google Tensorflow.
How do I fix CVE-2020-15213?
Upgrade tensorflow to a fixed version for your release line: 2.2.1 or 2.3.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-15213 being exploited?
There is no known exploitation of CVE-2020-15213 in the wild and no public exploit code.
Other vulnerabilities in Google Tensorflow
- CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
- CVE-2021-37678 Arbitrary code execution due to YAML deserialization
- CVE-2021-35958 Path traversal in n/a
- CVE-2020-15202 Integer truncation in Shard API usage
Sources
Also known as BIT-tensorflow-2020-15213, GHSA-hjmq-236j-8m87, PYSEC-2020-136, PYSEC-2020-293, PYSEC-2020-328.