# CVE-2020-15213: Denial of service in tensorflow-lite

> Attackers can cause denial of service in TensorFlow Lite by triggering excessive memory allocation via crafted segment sum models.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-tensorflow-2020-15213, GHSA-hjmq-236j-8m87, PYSEC-2020-136, PYSEC-2020-293, PYSEC-2020-328

## What is CVE-2020-15213?

CVE-2020-15213 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 25 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In TensorFlow Lite before versions 2.2.1 and 2.3.1, models using segment sum can trigger a denial of service by causing an out of memory allocation in the implementation of segment sum. Since code uses the last element of the tensor holding them to determine the dimensionality of output tensor, attackers can use a very large value to trigger a large allocation. The issue is patched in commit 204945b19e44b57906c9344c0d00120eeeae178a and is released in TensorFlow versions 2.2.1, or 2.3.1. A potential workaround would be to add a custom `Verifier` to limit the maximum value in the segment ids tensor. This only handles the case when the segment ids are stored statically in the model, but a similar validation could be done if the segment ids are generated at runtime, between inference steps. However, if the segment ids are generated as outputs of a tensor during inference steps, then there are no possible workaround and users are advised to upgrade to patched code.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2020-15213?

16 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | Bitnami | From 2.2.0 | 2.2.1, 2.3.1 |
| `tensorflow` | PyPI | From 2.2.0 | 2.2.1, 2.3.1 |
| `tensorflow` | PyPI | From 2.2.0 | 2.2.1 |
| `tensorflow` | PyPI | From 2.2.0 | 2.2.1 |
| `tensorflow` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow-cpu` | PyPI | From 2.2.0 | 2.2.1, 2.3.1 |
| `tensorflow-cpu` | PyPI | From 2.2.0 | 2.2.1 |
| `tensorflow-cpu` | PyPI | From 2.2.0 | 2.2.1 |
| `tensorflow-cpu` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow-cpu` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow-gpu` | PyPI | From 2.2.0 | 2.2.1, 2.3.1 |
| `tensorflow-gpu` | PyPI | From 2.2.0 | 2.2.1 |
| `tensorflow-gpu` | PyPI | From 2.2.0 | 2.2.1 |
| `tensorflow-gpu` | PyPI | From 2.3.0 | 2.3.1 |
| `tensorflow-gpu` | PyPI | From 2.3.0 | 2.3.1 |

Products: Google Tensorflow.

## How do I fix CVE-2020-15213?

Upgrade tensorflow to a fixed version for your release line: 2.2.1 or 2.3.1.

## Is CVE-2020-15213 being exploited?

There is no known exploitation of CVE-2020-15213 in the wild and no public exploit code.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15213 and fix it if it is affected.

What it is: CVE-2020-15213 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 25 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15213 in the wild and no public exploit code.

Affected packages and fixed versions:
- tensorflow (Bitnami): affected from 2.2.0; fixed in 2.2.1, 2.3.1
- tensorflow (PyPI): affected from 2.2.0; fixed in 2.2.1, 2.3.1
- tensorflow (PyPI): affected from 2.2.0; fixed in 2.2.1
- tensorflow (PyPI): affected from 2.2.0; fixed in 2.2.1
- tensorflow (PyPI): affected from 2.3.0; fixed in 2.3.1
- tensorflow (PyPI): affected from 2.3.0; fixed in 2.3.1
- tensorflow-cpu (PyPI): affected from 2.2.0; fixed in 2.2.1, 2.3.1
- tensorflow-cpu (PyPI): affected from 2.2.0; fixed in 2.2.1
- tensorflow-cpu (PyPI): affected from 2.2.0; fixed in 2.2.1
- tensorflow-cpu (PyPI): affected from 2.3.0; fixed in 2.3.1
- tensorflow-cpu (PyPI): affected from 2.3.0; fixed in 2.3.1
- tensorflow-gpu (PyPI): affected from 2.2.0; fixed in 2.2.1, 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15213/ (Markdown: https://insights.sbomify.com/CVE-2020-15213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15213
- OSV: https://osv.dev/vulnerability/CVE-2020-15213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15213/
Summaries are generated and may contain mistakes; the official description above is the record.
