CVE-2020-15217 User data exposure in GLPI
Medium 5.3
Published
Updated
Check this codebase for CVE-2020-15217 and fix it if it is affected.
What it is: CVE-2020-15217 is a medium-severity vulnerability in Glpi-Project Glpi, published on 7 Oct 2020.
Exploitation: There is no known exploitation of CVE-2020-15217 in the wild and no public exploit code.
Affected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2020-15217/ (Markdown: https://insights.sbomify.com/CVE-2020-15217/index.md)
- Exploited in the wild
- Not known
- Fix
- None listed
What is CVE-2020-15217?
CVE-2020-15217 is a medium-severity vulnerability in Glpi-Project Glpi, published on 7 Oct 2020.
Official description
In GLPI before version 9.5.2, there is a leakage of user information through the public FAQ. The issue was introduced in version 9.5.0 and patched in 9.5.2. As a workaround, disable public access to the FAQ.
Weakness: CWE-79
Which versions are affected by CVE-2020-15217?
It affects 1 product.
Products include Glpi-Project Glpi.
How do I fix CVE-2020-15217?
No fix has been published for CVE-2020-15217 yet. Limit exposure of the affected software until one is available.
Is CVE-2020-15217 being exploited?
There is no known exploitation of CVE-2020-15217 in the wild and no public exploit code.
Other vulnerabilities in Glpi-Project Glpi
- CVE-2022-35914 Teclib GLPI Remote Code Execution
- CVE-2023-42802 GLPI vulnerable to unallowed PHP script execution
- CVE-2023-28849 GLPI vulnerable to SQL injection and Stored XSS via inventory agent request
- CVE-2022-35947 SQL injection in GLPI
- CVE-2022-31056 SQL injection with _actor parameter in GLPI
Sources
Also known as GHSA-x9hg-j29f-wvvv.