CVE-2020-15227 Remote Code Execution vulnerability
Attackers can execute arbitrary code by sending specially crafted parameters to URLs in the Nette PHP framework.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15227?
CVE-2020-15227 is a high-severity code injection vulnerability in Debian Debian Linux, published on 1 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Nette versions before 2.0.19, 2.1.13, 2.2.10, 2.3.14, 2.4.16, 3.0.6 are vulnerable to an code injection attack by passing specially formed parameters to URL that may possibly leading to RCE. Nette is a PHP/Composer MVC Framework.
Which versions are affected by CVE-2020-15227?
12 open source packages ship an affected version, including nette/application. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
nette/application Packagist | From 2.0.0 | 2.0.19 |
nette/application Packagist | From 2.0.0 | 2.0.19 |
nette/application Packagist | From 2.1.0 | 2.1.13 |
nette/application Packagist | From 2.1.0 | 2.1.13 |
nette/application Packagist | From 2.2.0 | 2.2.10 |
nette/application Packagist | From 2.2.0 | 2.2.10 |
6 more packages
nette/application Packagist | From 2.3.0 | 2.3.14 |
nette/application Packagist | From 2.3.0 | 2.3.14 |
nette/application Packagist | From 2.4.0 | 2.4.16 |
nette/application Packagist | From 2.4.0 | 2.4.16 |
nette/application Packagist | From 3.0.0 | 3.0.6 |
nette/application Packagist | From 3.0.0 | 3.0.6 |
Products include Debian Debian Linux, Nette Application.
How do I fix CVE-2020-15227?
Upgrade nette/application to a fixed version for your release line: 2.0.19, 2.1.13, 2.2.10 or 2.3.14.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2020-15227 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-15227 exists.
Public exploit code: 1 Nuclei template and 3 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DLA-2617-1, GHSA-8gv3-3j7f-wg94, UBUNTU-CVE-2020-15227, USN-5983-1.