{"answers":{"affected":"2 open source packages ship an affected version, including @actions/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15228 in the wild and no public exploit code.","fix":"Upgrade @actions/core to 1.2.6 or later.","what":"CVE-2020-15228 is a low-severity command injection vulnerability in actions toolkit, published on 1 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-15228 and fix it if it is affected.\n\nWhat it is: CVE-2020-15228 is a low-severity command injection vulnerability in actions toolkit, published on 1 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-15228 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @actions/core (npm): affected all versions; fixed in 1.2.6\n- @actions/core (npm): affected all versions; fixed in 1.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15228/ (Markdown: https://insights.sbomify.com/CVE-2020-15228/index.md)","id":"CVE-2020-15228","markdown":"https://insights.sbomify.com/CVE-2020-15228/index.md","name":"CVE-2020-15228","record":{"aliases":["GHSA-mfwh-5m23-j46w"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"GitHub Actions toolkit","requires_auth":"low_privilege","summary":"Attackers can inject commands via stdout to modify environment variables or paths, potentially leading to code execution in GitHub Actions workflows.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"toolkit","vendor":"toolkit_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"In the `@actions/core` npm module before version 1.2.6,`addPath` and `exportVariable` functions communicate with the Actions Runner over stdout by generating a string in a specific format. Workflows that log untrusted data to stdout may invoke these commands, resulting in the path or environment variables being modified without the intention of the workflow or action author. The runner will release an update that disables the `set-env` and `add-path` workflow commands in the near future. For now, users should upgrade to `@actions/core v1.2.6` or later, and replace any instance of the `set-env` or `add-path` commands in their workflows with the new Environment File Syntax. Workflows and actions using the old commands or older versions of the toolkit will start to warn, then error out during workflow execution.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2020-11-12","github_poc":1,"max_poc_stars":7,"metasploit":0,"nuclei":0,"refs":[{"date":"2020-11-12T11:59:47Z","kind":"github_poc","ref":"https://github.com/guettli/fix-CVE-2020-15228","stars":7,"title":"Fix CVE-2020-15228 (set-env, add-path in Github-Actions)"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Environment Variable Injection in GitHub Actions","id":"CVE-2020-15228","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Path traversal and files overwrite with unsquashfs","id":"CVE-2020-15229"},"packages":[{"ecosystem":"npm","fixed":["1.2.6"],"introduced":["0"],"last_affected":[],"package":"@actions/core","purl":null,"source":"GHSA-mfwh-5m23-j46w"},{"ecosystem":"npm","fixed":["1.2.6"],"introduced":["0"],"last_affected":[],"package":"@actions/core","purl":"pkg:npm/%40actions/core","source":"GHSA-mfwh-5m23-j46w"}],"prev":{"headline":"Remote Code Execution vulnerability","id":"CVE-2020-15227"},"products":["toolkit"],"published":"2020-10-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["actions"]},"summary":"Attackers can inject commands via stdout to modify environment variables or paths, potentially leading to code execution in GitHub Actions workflows.","url":"https://insights.sbomify.com/CVE-2020-15228/"}