# CVE-2020-15228: Environment Variable Injection in GitHub Actions

> Attackers can inject commands via stdout to modify environment variables or paths, potentially leading to code execution in GitHub Actions workflows.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-mfwh-5m23-j46w

## What is CVE-2020-15228?

CVE-2020-15228 is a low-severity command injection vulnerability in actions toolkit, published on 1 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In the `@actions/core` npm module before version 1.2.6,`addPath` and `exportVariable` functions communicate with the Actions Runner over stdout by generating a string in a specific format. Workflows that log untrusted data to stdout may invoke these commands, resulting in the path or environment variables being modified without the intention of the workflow or action author. The runner will release an update that disables the `set-env` and `add-path` workflow commands in the near future. For now, users should upgrade to `@actions/core v1.2.6` or later, and replace any instance of the `set-env` or `add-path` commands in their workflows with the new Environment File Syntax. Workflows and actions using the old commands or older versions of the toolkit will start to warn, then error out during workflow execution.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-15228?

2 open source packages ship an affected version, including @actions/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@actions/core` | npm | All versions | 1.2.6 |
| `@actions/core` | npm | All versions | 1.2.6 |

Products: Toolkit Project Toolkit.

## How do I fix CVE-2020-15228?

Upgrade @actions/core to 1.2.6 or later.

## Is CVE-2020-15228 being exploited?

There is no known exploitation of CVE-2020-15228 in the wild and no public exploit code.

Public exploit code:

- Fix CVE-2020-15228 (set-env, add-path in Github-Actions) (github_poc): https://github.com/guettli/fix-CVE-2020-15228

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15228 and fix it if it is affected.

What it is: CVE-2020-15228 is a low-severity command injection vulnerability in actions toolkit, published on 1 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15228 in the wild and no public exploit code.

Affected packages and fixed versions:
- @actions/core (npm): affected all versions; fixed in 1.2.6
- @actions/core (npm): affected all versions; fixed in 1.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15228/ (Markdown: https://insights.sbomify.com/CVE-2020-15228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15228
- OSV: https://osv.dev/vulnerability/CVE-2020-15228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15228/
Summaries are generated and may contain mistakes; the official description above is the record.
