# CVE-2020-15230: Arbitrary file read un Vapor

> Attackers can read arbitrary files on the host if the application uses FileMiddleware, requiring an upgrade to the Vapor framework.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vcvg-xgr8-p5gq

## What is CVE-2020-15230?

CVE-2020-15230 is a high-severity path traversal vulnerability in vapor, published on 2 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vapor is a web framework for Swift. In Vapor before version 4.29.4, Attackers can access data at arbitrary filesystem paths on the same host as an application. Only applications using FileMiddleware are affected. This is fixed in version 4.29.4.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-15230?

2 open source packages ship an affected version, including github.com/vapor/vapor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/vapor/vapor` | SwiftURL | From 4.0.0-rc.2.5 | 4.29.4 |
| `github.com/vapor/vapor` | SwiftURL | From 4.0.0-rc.2.5 | 4.29.4 |

Products: Vapor Project Vapor.

## How do I fix CVE-2020-15230?

Upgrade github.com/vapor/vapor to 4.29.4 or later.

## Is CVE-2020-15230 being exploited?

There is no known exploitation of CVE-2020-15230 in the wild and no public exploit code.

## Other vulnerabilities in vapor

- [CVE-2021-32742](https://insights.sbomify.com/CVE-2021-32742/): Untrusted data fed into `Data.init(base32Encoded:)` can result in exposing server memory and/or crash (high 7.5)
- [CVE-2021-21328](https://insights.sbomify.com/CVE-2021-21328/): Denial of Service (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15230 and fix it if it is affected.

What it is: CVE-2020-15230 is a high-severity path traversal vulnerability in vapor, published on 2 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15230 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/vapor/vapor (SwiftURL): affected from 4.0.0-rc.2.5; fixed in 4.29.4
- github.com/vapor/vapor (SwiftURL): affected from 4.0.0-rc.2.5; fixed in 4.29.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15230/ (Markdown: https://insights.sbomify.com/CVE-2020-15230/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15230
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15230
- OSV: https://osv.dev/vulnerability/CVE-2020-15230

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15230/
Summaries are generated and may contain mistakes; the official description above is the record.
