{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2020-15238 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2020-15238 is a high-severity command injection vulnerability in Debian Debian Linux, published on 27 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-15238 and fix it if it is affected.\n\nWhat it is: CVE-2020-15238 is a high-severity command injection vulnerability in Debian Debian Linux, published on 27 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-15238 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15238/ (Markdown: https://insights.sbomify.com/CVE-2020-15238/index.md)","id":"CVE-2020-15238","markdown":"https://insights.sbomify.com/CVE-2020-15238/index.md","name":"CVE-2020-15238","record":{"aliases":["DEBIAN-CVE-2020-15238","DLA-2430-1","DSA-4781-1","GHSA-jpc9-mgw6-2xwx","MGASA-2020-0402","UBUNTU-CVE-2020-15238","USN-4605-1","USN-4605-2","openSUSE-SU-2020:1997-1","openSUSE-SU-2020:2024-1","openSUSE-SU-2024:10656-1"],"analysis":{"component_type":"desktop_application","fix_type":"patch","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Blueman Bluetooth Manager","requires_auth":"low_privilege","summary":"Local attackers can inject arguments into D-Bus methods to execute arbitrary commands or scripts, leading to privilege escalation.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"blueman","vendor":"blueman_project"},{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Blueman is a GTK+ Bluetooth Manager. In Blueman before 2.1.4, the DhcpClient method of the D-Bus interface to blueman-mechanism is prone to an argument injection vulnerability. The impact highly depends on the system configuration. If Polkit-1 is disabled and for versions lower than 2.0.6, any local user can possibly exploit this. If Polkit-1 is enabled for version 2.0.6 and later, a possible attacker needs to be allowed to use the `org.blueman.dhcp.client` action. That is limited to users in the wheel group in the shipped rules file that do have the privileges anyway. On systems with ISC DHCP client (dhclient), attackers can pass arguments to `ip link` with the interface name that can e.g. be used to bring down an interface or add an arbitrary XDP/BPF program. On systems with dhcpcd and without ISC DHCP client, attackers can even run arbitrary scripts by passing `-c/path/to/script` as an interface name. Patches are included in 2.1.4 and master that change the DhcpClient D-Bus method(s) to accept BlueZ network object paths instead of network interface names. A backport to 2.0(.8) is also available. As a workaround, make sure that Polkit-1-support is enabled and limit privileges for the `org.blueman.dhcp.client` action to users that are able to run arbitrary commands as root anyway in /usr/share/polkit-1/rules.d/blueman.rules.","ecosystems":["SUSE:Package Hub 15 SP2","openSUSE:Leap 15.2"],"exploits":{"exploitdb":1,"first_seen":"2020-10-28","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2020-10-28","kind":"exploitdb","ref":"48963","stars":null,"title":"Blueman \u003c 2.1.4 - Local Privilege Escalation"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Local privilege escalation Blueman","id":"CVE-2020-15238","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora"],"type":"command_injection","year":"2020"},"n_packages":3,"n_references":10,"next":{"headline":"Directory Traversal in xmpp-http-upload","id":"CVE-2020-15239"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP2","fixed":["2.1.4-bp152.2.3.1"],"introduced":["0"],"last_affected":[],"package":"blueman","purl":"pkg:rpm/suse/blueman\u0026distro=SUSE%20Package%20Hub%2015%20SP2","source":"openSUSE-SU-2020:1997-1"},{"ecosystem":"SUSE:Package Hub 15 SP2","fixed":["2.1.4-bp152.2.6.1"],"introduced":["0"],"last_affected":[],"package":"blueman","purl":"pkg:rpm/suse/blueman\u0026distro=SUSE%20Package%20Hub%2015%20SP2","source":"openSUSE-SU-2020:2024-1"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["2.1.4-bp152.2.3.1"],"introduced":["0"],"last_affected":[],"package":"blueman","purl":"pkg:rpm/opensuse/blueman\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2020:1997-1"}],"prev":{"headline":"Timing attack in Shrine","id":"CVE-2020-15237"},"products":["blueman"],"published":"2020-10-27","related":[{"cvss_score":8.4,"headline":"The EnableNetwork method in the Network class in plugins/mechanism/Network.py in Blueman before 2.0.3 allows local users to gain privileges","id":"CVE-2015-8612","kev_date_added":null,"published":"2016-01-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["blueman-project"]},"summary":"Local attackers can inject arguments into D-Bus methods to execute arbitrary commands or scripts, leading to privilege escalation.","url":"https://insights.sbomify.com/CVE-2020-15238/"}