CVE-2020-15240 Regression in JWT Signature Validation

High 7.4 Published Updated

Attackers can bypass authentication and authorization by exploiting improper JWT signature validation in specific usage scenarios.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-15240?

CVE-2020-15240 is a high-severity authentication bypass vulnerability in omniauth-auth0, published on 21 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify` method. Improper validation of the JWT token signature can allow an attacker to bypass authentication and authorization. You are affected by this vulnerability if all of the following conditions apply: 1. You are using `omniauth-auth0`. 2. You are using `JWTValidator.verify` method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. The issue is patched in version 2.4.1.

Weakness: CWE-347, CWE-287

Which versions are affected by CVE-2020-15240?

2 open source packages ship an affected version, including omniauth-auth0. It affects 1 product.

PackageAffectedFixed in
omniauth-auth0 RubyGemsFrom 2.3.02.4.1
omniauth-auth0 RubyGemsFrom 2.3.02.4.1

Products include Auth0 Omniauth-Auth0.

How do I fix CVE-2020-15240?

Upgrade omniauth-auth0 to 2.4.1 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2020-15240 being exploited?

There is no known exploitation of CVE-2020-15240 in the wild and no public exploit code.

Sources

Also known as GHSA-58r4-h6v8-jcvm.

Is CVE-2020-15240 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free