{"answers":{"affected":"2 open source packages ship an affected version, including omniauth-auth0. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15240 in the wild and no public exploit code.","fix":"Upgrade omniauth-auth0 to 2.4.1 or later.","what":"CVE-2020-15240 is a high-severity authentication bypass vulnerability in omniauth-auth0, published on 21 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-15240 and fix it if it is affected.\n\nWhat it is: CVE-2020-15240 is a high-severity authentication bypass vulnerability in omniauth-auth0, published on 21 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-15240 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- omniauth-auth0 (RubyGems): affected from 2.3.0; fixed in 2.4.1\n- omniauth-auth0 (RubyGems): affected from 2.3.0; fixed in 2.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15240/ (Markdown: https://insights.sbomify.com/CVE-2020-15240/index.md)","id":"CVE-2020-15240","markdown":"https://insights.sbomify.com/CVE-2020-15240/index.md","name":"CVE-2020-15240","record":{"aliases":["GHSA-58r4-h6v8-jcvm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby authentication library","requires_auth":"none","summary":"Attackers can bypass authentication and authorization by exploiting improper JWT signature validation in specific usage scenarios.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"omniauth-auth0","vendor":"auth0"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"omniauth-auth0 (rubygems) versions \u003e= 2.3.0 and \u003c 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify` method. Improper validation of the JWT token signature can allow an attacker to bypass authentication and authorization. You are affected by this vulnerability if all of the following conditions apply: 1. You are using `omniauth-auth0`. 2. You are using `JWTValidator.verify` method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. The issue is patched in version 2.4.1.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regression in JWT Signature Validation","id":"CVE-2020-15240","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"auth_bypass","year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-Site Scripting in TYPO3 Fluid Engine","id":"CVE-2020-15241"},"packages":[{"ecosystem":"RubyGems","fixed":["2.4.1"],"introduced":["2.3.0"],"last_affected":[],"package":"omniauth-auth0","purl":null,"source":"GHSA-58r4-h6v8-jcvm"},{"ecosystem":"RubyGems","fixed":["2.4.1"],"introduced":["2.3.0"],"last_affected":[],"package":"omniauth-auth0","purl":"pkg:gem/omniauth-auth0","source":"GHSA-58r4-h6v8-jcvm"}],"prev":{"headline":"Directory Traversal in xmpp-http-upload","id":"CVE-2020-15239"},"products":["omniauth-auth0"],"published":"2020-10-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["auth0"]},"summary":"Attackers can bypass authentication and authorization by exploiting improper JWT signature validation in specific usage scenarios.","url":"https://insights.sbomify.com/CVE-2020-15240/"}