# CVE-2020-15240: Regression in JWT Signature Validation

> Attackers can bypass authentication and authorization by exploiting improper JWT signature validation in specific usage scenarios.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-58r4-h6v8-jcvm

## What is CVE-2020-15240?

CVE-2020-15240 is a high-severity authentication bypass vulnerability in omniauth-auth0, published on 21 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify` method. Improper validation of the JWT token signature can allow an attacker to bypass authentication and authorization. You are affected by this vulnerability if all of the following conditions apply: 1. You are using `omniauth-auth0`. 2. You are using `JWTValidator.verify` method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. The issue is patched in version 2.4.1.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2020-15240?

2 open source packages ship an affected version, including omniauth-auth0. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `omniauth-auth0` | RubyGems | From 2.3.0 | 2.4.1 |
| `omniauth-auth0` | RubyGems | From 2.3.0 | 2.4.1 |

Products: Auth0 Omniauth-Auth0.

## How do I fix CVE-2020-15240?

Upgrade omniauth-auth0 to 2.4.1 or later.

## Is CVE-2020-15240 being exploited?

There is no known exploitation of CVE-2020-15240 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15240 and fix it if it is affected.

What it is: CVE-2020-15240 is a high-severity authentication bypass vulnerability in omniauth-auth0, published on 21 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15240 in the wild and no public exploit code.

Affected packages and fixed versions:
- omniauth-auth0 (RubyGems): affected from 2.3.0; fixed in 2.4.1
- omniauth-auth0 (RubyGems): affected from 2.3.0; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15240/ (Markdown: https://insights.sbomify.com/CVE-2020-15240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15240
- OSV: https://osv.dev/vulnerability/CVE-2020-15240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15240/
Summaries are generated and may contain mistakes; the official description above is the record.
