# CVE-2020-15242: Open Redirect in Next.js

> Attackers can redirect users from a trusted Next.js site to malicious external domains, facilitating phishing attacks.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-x56p-c8cg-q435

## What is CVE-2020-15242?

CVE-2020-15242 is a medium-severity vulnerability in Vercel Next.js, published on 8 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Next.js versions >=9.5.0 and <9.5.4 are vulnerable to an Open Redirect. Specially encoded paths could be used with the trailing slash redirect to allow an open redirect to occur to an external site. In general, this redirect does not directly harm users although can allow for phishing attacks by redirecting to an attackers domain from a trusted domain. The issue is fixed in version 9.5.4.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2020-15242?

2 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 9.5.0 | 9.5.4 |
| `next` | npm | From 9.5.0 | 9.5.4 |

Products: Vercel Next.js.

## How do I fix CVE-2020-15242?

Upgrade next to 9.5.4 or later.

## Is CVE-2020-15242 being exploited?

There is no known exploitation of CVE-2020-15242 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15242 and fix it if it is affected.

What it is: CVE-2020-15242 is a medium-severity vulnerability in Vercel Next.js, published on 8 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15242 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 9.5.0; fixed in 9.5.4
- next (npm): affected from 9.5.0; fixed in 9.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15242/ (Markdown: https://insights.sbomify.com/CVE-2020-15242/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15242
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15242
- OSV: https://osv.dev/vulnerability/CVE-2020-15242

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15242/
Summaries are generated and may contain mistakes; the official description above is the record.
