CVE-2020-15244 RCE in Magento

High 8.0 Published Updated

An admin user can achieve remote code execution via PHP object injection in Magento by manipulating product attributes and SOAP credentials.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-15244?

CVE-2020-15244 is a high-severity unsafe deserialization vulnerability in OpenMage magento-lts, published on 21 Oct 2020. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

In Magento (rubygems openmage/magento-lts package) before versions 19.4.8 and 20.0.4, an admin user can generate soap credentials that can be used to trigger RCE via PHP Object Injection through product attributes and a product. The issue is patched in versions 19.4.8 and 20.0.4.

Weakness: CWE-74, CWE-502

Which versions are affected by CVE-2020-15244?

4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.

PackageAffectedFixed in
openmage/magento-lts PackagistAll versions19.4.8
openmage/magento-lts PackagistAll versions19.4.8
openmage/magento-lts PackagistFrom 20.0.020.0.4
openmage/magento-lts PackagistFrom 20.0.020.0.4

Products include Openmage Magento.

How do I fix CVE-2020-15244?

Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.8 or 20.0.4.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2020-15244 being exploited?

There is no known exploitation of CVE-2020-15244 in the wild and no public exploit code.

Sources

Also known as GHSA-jrgf-vfw2-hj26.

Is CVE-2020-15244 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free