# CVE-2020-15245: Email verification bypass in Sylius

> Attackers can bypass email verification by changing their email after initial verification, resulting in unverified accounts being marked as verified.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6gw4-x63h-5499

## What is CVE-2020-15245?

CVE-2020-15245 is a medium-severity vulnerability in Sylius, published on 19 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Sylius before versions 1.6.9, 1.7.9 and 1.8.3, the user may register in a shop by email mail@example.com, verify it, change it to the mail another@domain.com and stay verified and enabled. This may lead to having accounts addressed to totally different emails, that were verified. Note, that this way one is not able to take over any existing account (guest or normal one). The issue has been patched in Sylius 1.6.9, 1.7.9 and 1.8.3. As a workaround, you may resolve this issue on your own by creating a custom event listener, which will listen to the sylius.customer.pre_update event. You can determine that email has been changed if customer email and user username are different. They are synchronized later on. Pay attention, to email changing behavior for administrators. You may need to skip this logic for them. In order to achieve this, you should either check master request path info, if it does not contain /admin prefix or adjust event triggered during customer update in the shop. You can find more information on how to customize the event here.

Weakness: CWE-862 (Missing Authorization), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-15245?

6 open source packages ship an affected version, including sylius/sylius. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/sylius` | Packagist | From 1.0.0 | 1.6.9 |
| `sylius/sylius` | Packagist | From 1.0.0 | 1.6.9 |
| `sylius/sylius` | Packagist | From 1.7.0 | 1.7.9 |
| `sylius/sylius` | Packagist | From 1.7.0 | 1.7.9 |
| `sylius/sylius` | Packagist | From 1.8.0 | 1.8.3 |
| `sylius/sylius` | Packagist | From 1.8.0 | 1.8.3 |

Products: Sylius Sylius.

## How do I fix CVE-2020-15245?

Upgrade sylius/sylius to a fixed version for your release line: 1.6.9, 1.7.9 or 1.8.3.

## Is CVE-2020-15245 being exploited?

There is no known exploitation of CVE-2020-15245 in the wild and no public exploit code.

## Other vulnerabilities in Sylius

- [CVE-2026-31824](https://insights.sbomify.com/CVE-2026-31824/): Sylius has a Promotion Usage Limit Bypass via Race Condition (high 8.2)
- [CVE-2024-57610](https://insights.sbomify.com/CVE-2024-57610/): Denial of service in n/a (high 7.5)
- [CVE-2026-31820](https://insights.sbomify.com/CVE-2026-31820/): Sylius affected by IDOR in Cart and Checkout LiveComponents (high 7.1)
- [CVE-2022-24743](https://insights.sbomify.com/CVE-2022-24743/): Insufficient Session Expiration in Sylius (high 7.1)
- [CVE-2026-31819](https://insights.sbomify.com/CVE-2026-31819/): Sylius has an Open Redirect via Referer Header (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15245 and fix it if it is affected.

What it is: CVE-2020-15245 is a medium-severity vulnerability in Sylius, published on 19 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15245 in the wild and no public exploit code.

Affected packages and fixed versions:
- sylius/sylius (Packagist): affected from 1.0.0; fixed in 1.6.9
- sylius/sylius (Packagist): affected from 1.0.0; fixed in 1.6.9
- sylius/sylius (Packagist): affected from 1.7.0; fixed in 1.7.9
- sylius/sylius (Packagist): affected from 1.7.0; fixed in 1.7.9
- sylius/sylius (Packagist): affected from 1.8.0; fixed in 1.8.3
- sylius/sylius (Packagist): affected from 1.8.0; fixed in 1.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15245/ (Markdown: https://insights.sbomify.com/CVE-2020-15245/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15245
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15245
- OSV: https://osv.dev/vulnerability/CVE-2020-15245

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15245/
Summaries are generated and may contain mistakes; the official description above is the record.
