# CVE-2020-15250: Information disclosure in JUnit4


- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 12 Oct 2020
- **Updated:** 7 Oct 2026
- **Also known as:** AZL-41745, CLEANSTART-2025-SF33121, CLSA-2026-1779151613, CLSA-2026-1792655995, DEBIAN-CVE-2020-15250, DLA-2426-1, GHSA-269g-pwp5-87pp, MGASA-2020-0403, OESA-2021-1053, RHLW-2026-8de53cade32781fb, RHLW-2026-aabbc2804b02664a, UBUNTU-CVE-2020-15250, USN-4731-1

## What is CVE-2020-15250?

CVE-2020-15250 is a medium-severity vulnerability in Debian Debian Linux, published on 12 Oct 2020. 

### Official description

In JUnit4 from version 4.7 and before 4.13.1, the test rule TemporaryFolder contains a local information disclosure vulnerability. On Unix like systems, the system's temporary directory is shared between all users on that system. Because of this, when files and directories are written into this directory they are, by default, readable by other users on that same system. This vulnerability does not allow other users to overwrite the contents of these directories or files. This is purely an information disclosure vulnerability. This vulnerability impacts you if the JUnit tests write sensitive information, like API keys or passwords, into the temporary folder, and the JUnit tests execute in an environment where the OS has other untrusted users. Because certain JDK file system APIs were only added in JDK 1.7, this this fix is dependent upon the version of the JDK you are using. For Java 1.7 and higher users: this vulnerability is fixed in 4.13.1. For Java 1.6 and lower users: no patch is available, you must use the workaround below. If you are unable to patch, or are stuck running on Java 1.6, specifying the `java.io.tmpdir` system environment variable to a directory that is exclusively owned by the executing user will fix this vulnerability. For more information, including an example of vulnerable code, see the referenced GitHub Security Advisory.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2020-15250?

2 open source packages ship an affected version, including junit:junit. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `junit:junit` | Maven | From 4.7 | 4.13.1 |
| `junit:junit` | Maven | From 4.7 | 4.13.1 |

Products: Apache Pluto, Debian Debian Linux, Junit Junit4, Oracle Communications Cloud Native Core Policy.

## How do I fix CVE-2020-15250?

Upgrade junit:junit to 4.13.1 or later.

## Is CVE-2020-15250 being exploited?

There is no known exploitation of CVE-2020-15250 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2018-1306](https://insights.sbomify.com/CVE-2018-1306/): Exposure of Sensitive Information in Apache Pluto (high 7.5)
- [CVE-2021-36737](https://insights.sbomify.com/CVE-2021-36737/): XSS in V3 Demo Portlet (medium 6.1)
- [CVE-2021-36738](https://insights.sbomify.com/CVE-2021-36738/): XSS vulnerability in the JSP version of the Apache Pluto Applicant MVCBean CDI portlet (medium 6.1)
- [CVE-2021-36739](https://insights.sbomify.com/CVE-2021-36739/): XSS vulnerability in the MVCBean JSP portlet maven archetype (medium 6.1)
- [CVE-2019-0186](https://insights.sbomify.com/CVE-2019-0186/): Cross-site Scripting in Apache Pluto Chatroom demo (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15250 and fix it if it is affected.

What it is: CVE-2020-15250 is a medium-severity vulnerability in Debian Debian Linux, published on 12 Oct 2020. 
Exploitation: There is no known exploitation of CVE-2020-15250 in the wild and no public exploit code.

Affected packages and fixed versions:
- junit:junit (Maven): affected from 4.7; fixed in 4.13.1
- junit:junit (Maven): affected from 4.7; fixed in 4.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15250/ (Markdown: https://insights.sbomify.com/CVE-2020-15250/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15250
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15250
- OSV: https://osv.dev/vulnerability/CVE-2020-15250

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15250/
Summaries are generated and may contain mistakes; the official description above is the record.
