CVE-2020-15252 RCE in XWiki

High 8.5 Published Updated

Users with script rights can execute arbitrary code by accessing the Servlet context to instantiate Java objects.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-15252?

CVE-2020-15252 is a high-severity code injection vulnerability in Xwiki Xwiki, published on 16 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In XWiki before version 12.5 and 11.10.6, any user with SCRIPT right (EDIT right before XWiki 7.4) can gain access to the application server Servlet context which contains tools allowing to instantiate arbitrary Java objects and invoke methods that may lead to arbitrary code execution. This is patched in XWiki 12.5 and XWiki 11.10.6.

Weakness: CWE-74, CWE-94

Which versions are affected by CVE-2020-15252?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.

PackageAffectedFixed in
org.xwiki.platform:xwiki-platform-oldcore MavenAll versions11.10.6
org.xwiki.platform:xwiki-platform-oldcore MavenAll versions11.10.6
org.xwiki.platform:xwiki-platform-oldcore MavenFrom 12.012.5
org.xwiki.platform:xwiki-platform-oldcore MavenFrom 12.012.5

Products include Xwiki Xwiki.

How do I fix CVE-2020-15252?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 11.10.6 or 12.5.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2020-15252 being exploited?

There is no known exploitation of CVE-2020-15252 in the wild and no public exploit code.

All Xwiki Xwiki vulnerabilities

Sources

Also known as GHSA-5hv6-mh8q-q9v8.

Is CVE-2020-15252 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free