CVE-2020-15257 containerd-shim API Exposed to Host Network Containers
Malicious containers sharing the host network namespace can escalate privileges to root via the exposed containerd-shim API socket.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15257?
CVE-2020-15257 is a medium-severity vulnerability in Debian Debian Linux, published on 1 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
containerd is an industry-standard container runtime and is available as a daemon for Linux and Windows. In containerd before versions 1.3.9 and 1.4.3, the containerd-shim API is improperly exposed to host network containers. Access controls for the shim’s API socket verified that the connecting process had an effective UID of 0, but did not otherwise restrict access to the abstract Unix domain socket. This would allow malicious containers running in the same network namespace as the shim, with an effective UID of 0 but otherwise reduced privileges, to cause new processes to be run with elevated privileges. This vulnerability has been fixed in containerd 1.3.9 and 1.4.3. Users should update to these versions as soon as they are released. It should be noted that containers started with an old version of containerd-shim should be stopped and restarted, as running containers will continue to be vulnerable even after an upgrade. If you are not providing the ability for untrusted users to start containers in the same network namespace as the shim (typically the "host" network namespace, for example with docker run --net=host or hostNetwork: true in a Kubernetes pod) and run with an effective UID of 0, you are not vulnerable to this issue. If you are running containers with a vulnerable configuration, you can deny access to all abstract sockets with AppArmor by adding a line similar to deny unix addr=@**, to your policy. It is best practice to run containers with a reduced set of privileges, with a non-zero UID, and with isolated namespaces. The containerd maintainers strongly advise against sharing namespaces with the host. Reducing the set of isolation mechanisms used for a container necessarily increases that container's privilege, regardless of what container runtime is used for running that container.
Weakness: CWE-669
Which versions are affected by CVE-2020-15257?
5 open source packages ship an affected version, including github.com/containerd/containerd. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/containerd/containerd Go | All versions | 1.3.9, 1.4.3 |
github.com/containerd/containerd Go | All versions | 1.3.9 |
github.com/containerd/containerd Go | All versions | 1.3.9 |
github.com/containerd/containerd Go | From 1.4.0 | 1.4.3 |
github.com/containerd/containerd Go | From 1.4.0 | 1.4.3 |
Linux distribution packages (4)
containerd SUSE:Linux Enterprise Module for Containers 12 | All versions | 1.3.9-16.32.1 |
docker SUSE:Linux Enterprise Module for Containers 12 | All versions | 19.03.14_ce-98.57.1 |
docker-runc SUSE:Linux Enterprise Module for Containers 12 | All versions | 1.0.0rc10+gitr3981_dc9208a3303f-1.49.1 |
golang-github-docker-libnetwork SUSE:Linux Enterprise Module for Containers 12 | All versions | 0.7.0.1+gitr2908_55e924b8a842-34.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Linuxfoundation Containerd.
How do I fix CVE-2020-15257?
Upgrade github.com/containerd/containerd to a fixed version for your release line: 1.3.9 or 1.4.3.
Is CVE-2020-15257 being exploited?
There is no known exploitation of CVE-2020-15257 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2025-IA92737, CLEANSTART-2026-KK84910, DEBIAN-CVE-2020-15257, GHSA-36xw-fx78-c5r4, GO-2022-0784, SUSE-SU-2020:3938-1 and 3 more.