# CVE-2020-15257: containerd-shim API Exposed to Host Network Containers

> Malicious containers sharing the host network namespace can escalate privileges to root via the exposed containerd-shim API socket.

- **Severity:** Medium 5.2 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** CLEANSTART-2025-IA92737, CLEANSTART-2026-KK84910, DEBIAN-CVE-2020-15257, GHSA-36xw-fx78-c5r4, GO-2022-0784, SUSE-SU-2020:3938-1, UBUNTU-CVE-2020-15257, USN-4653-1, USN-4653-2

## What is CVE-2020-15257?

CVE-2020-15257 is a medium-severity vulnerability in Debian Debian Linux, published on 1 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

containerd is an industry-standard container runtime and is available as a daemon for Linux and Windows. In containerd before versions 1.3.9 and 1.4.3, the containerd-shim API is improperly exposed to host network containers. Access controls for the shim’s API socket verified that the connecting process had an effective UID of 0, but did not otherwise restrict access to the abstract Unix domain socket. This would allow malicious containers running in the same network namespace as the shim, with an effective UID of 0 but otherwise reduced privileges, to cause new processes to be run with elevated privileges. This vulnerability has been fixed in containerd 1.3.9 and 1.4.3. Users should update to these versions as soon as they are released. It should be noted that containers started with an old version of containerd-shim should be stopped and restarted, as running containers will continue to be vulnerable even after an upgrade. If you are not providing the ability for untrusted users to start containers in the same network namespace as the shim (typically the "host" network namespace, for example with docker run --net=host or hostNetwork: true in a Kubernetes pod) and run with an effective UID of 0, you are not vulnerable to this issue. If you are running containers with a vulnerable configuration, you can deny access to all abstract sockets with AppArmor by adding a line similar to deny unix addr=@**, to your policy. It is best practice to run containers with a reduced set of privileges, with a non-zero UID, and with isolated namespaces. The containerd maintainers strongly advise against sharing namespaces with the host. Reducing the set of isolation mechanisms used for a container necessarily increases that container's privilege, regardless of what container runtime is used for running that container.

Weakness: CWE-669 (Incorrect Resource Transfer Between Spheres)

## Which versions are affected by CVE-2020-15257?

5 open source packages ship an affected version, including github.com/containerd/containerd. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containerd/containerd` | Go | All versions | 1.3.9, 1.4.3 |
| `github.com/containerd/containerd` | Go | All versions | 1.3.9 |
| `github.com/containerd/containerd` | Go | All versions | 1.3.9 |
| `github.com/containerd/containerd` | Go | From 1.4.0 | 1.4.3 |
| `github.com/containerd/containerd` | Go | From 1.4.0 | 1.4.3 |
| `containerd` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 1.3.9-16.32.1 |
| `docker` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 19.03.14_ce-98.57.1 |
| `docker-runc` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 1.0.0rc10+gitr3981_dc9208a3303f-1.49.1 |
| `golang-github-docker-libnetwork` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 0.7.0.1+gitr2908_55e924b8a842-34.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Linuxfoundation Containerd.

## How do I fix CVE-2020-15257?

Upgrade github.com/containerd/containerd to a fixed version for your release line: 1.3.9 or 1.4.3.

## Is CVE-2020-15257 being exploited?

There is no known exploitation of CVE-2020-15257 in the wild and no public exploit code.

Public exploit code:

- Proof of concept for CVE-2020-15257 in containerd. (github_poc): https://github.com/nccgroup/abstractshimmer

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15257 and fix it if it is affected.

What it is: CVE-2020-15257 is a medium-severity vulnerability in Debian Debian Linux, published on 1 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15257 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.3.9, 1.4.3
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.3.9
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.3.9
- github.com/containerd/containerd (Go): affected from 1.4.0; fixed in 1.4.3
- github.com/containerd/containerd (Go): affected from 1.4.0; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15257/ (Markdown: https://insights.sbomify.com/CVE-2020-15257/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15257
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15257
- OSV: https://osv.dev/vulnerability/CVE-2020-15257

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15257/
Summaries are generated and may contain mistakes; the official description above is the record.
