{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15258 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2020-15258 yet. Limit exposure of the affected software until one is available.","what":"CVE-2020-15258 is a high-severity code injection vulnerability in wireapp wire-desktop, published on 16 Oct 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15258 and fix it if it is affected.\n\nWhat it is: CVE-2020-15258 is a high-severity code injection vulnerability in wireapp wire-desktop, published on 16 Oct 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15258 in the wild and no public exploit code.\n\nAffected product: wireapp wire-desktop. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15258/ (Markdown: https://insights.sbomify.com/CVE-2020-15258/index.md)","id":"CVE-2020-15258","markdown":"https://insights.sbomify.com/CVE-2020-15258/index.md","name":"CVE-2020-15258","record":{"aliases":["GHSA-5gpx-9976-ggpm"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Wire desktop client","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary code on a victim's machine by sending messages with malicious links using non-standard protocols, requiring user interaction.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"wire","vendor":"wire"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"In Wire before 3.20.x, `shell.openExternal` was used without checking the URL. This vulnerability allows an attacker to execute code on the victims machine by sending messages containing links with arbitrary protocols. The victim has to interact with the link and sees the URL that is opened. The issue was patched by implementing a helper function which checks if the URL's protocol is common. If it is common, the URL will be opened externally. If not, the URL will not be opened and a warning appears for the user informing them that a probably insecure URL was blocked from being executed. The issue is patched in Wire 3.20.x. More technical details about exploitation are available in the linked advisory.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Insecure use of shell.openExternal in Wire","id":"CVE-2020-15258","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2020"},"n_packages":0,"n_references":3,"next":{"headline":"CSRF in Auth0 ad-ldap-connector","id":"CVE-2020-15259"},"packages":[],"prev":{"headline":"containerd-shim API Exposed to Host Network Containers","id":"CVE-2020-15257"},"products":["wire-desktop"],"published":"2020-10-16","related":[{"cvss_score":9.8,"headline":"Other in n/a","id":"CVE-2020-27853","kev_date_added":null,"published":"2020-10-27"},{"cvss_score":8.8,"headline":"Verified groups not reliable","id":"CVE-2021-32665","kev_date_added":null,"published":"2021-06-03"},{"cvss_score":7.5,"headline":"Path traversal in n/a","id":"CVE-2018-8909","kev_date_added":null,"published":"2018-03-22"},{"cvss_score":7.4,"headline":"Account takeover when having only access to a user's short lived token","id":"CVE-2021-41093","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":6.5,"headline":"wire-server vulnerable to unauthorized removal of Bots from Conversations","id":"CVE-2023-22737","kev_date_added":null,"published":"2023-01-27"},{"cvss_score":6.5,"headline":"DoS vulnerability: Malformed Resource Identifiers","id":"CVE-2022-23625","kev_date_added":null,"published":"2022-03-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["wireapp"]},"summary":"An attacker can execute arbitrary code on a victim's machine by sending messages with malicious links using non-standard protocols, requiring user interaction.","url":"https://insights.sbomify.com/CVE-2020-15258/"}