# CVE-2020-15259: CSRF in Auth0 ad-ldap-connector

> An attacker can exploit missing CSRF protection in the admin panel to achieve remote code execution or data loss if an admin visits a malicious page.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 6 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vx5q-cp9v-427v

## What is CVE-2020-15259?

CVE-2020-15259 is a high-severity vulnerability in auth0 ad-ldap-connector, published on 6 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ad-ldap-connector's admin panel before version 5.0.13 does not provide csrf protection, which when exploited may result in remote code execution or confidential data loss. CSRF exploits may occur if the user visits a malicious page containing CSRF payload on the same machine that has access to the ad-ldap-connector admin console via a browser. You may be affected if you use the admin console included with ad-ldap-connector versions <=5.0.12. If you do not have ad-ldap-connector admin console enabled or do not visit any other public URL while on the machine it is installed on, you are not affected. The issue is fixed in version 5.0.13.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2020-15259?

It affects 1 product.


Products: Auth0 Ad\/Ldap Connector.

## How do I fix CVE-2020-15259?

No fix has been published for CVE-2020-15259 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-15259 being exploited?

There is no known exploitation of CVE-2020-15259 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15259 and fix it if it is affected.

What it is: CVE-2020-15259 is a high-severity vulnerability in auth0 ad-ldap-connector, published on 6 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15259 in the wild and no public exploit code.

Affected product: auth0 ad-ldap-connector. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15259/ (Markdown: https://insights.sbomify.com/CVE-2020-15259/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15259
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15259
- OSV: https://osv.dev/vulnerability/CVE-2020-15259

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15259/
Summaries are generated and may contain mistakes; the official description above is the record.
