# CVE-2020-15262: Invalid integrity hashes in webpack-subresource-integrity

> Attackers can bypass Subresource Integrity checks for dynamically loaded chunks in webpack-subresource-integrity, removing browser validation protections.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** CLSA-2026-1774225212, CLSA-2026-1779238044, GHSA-4fc4-chg7-h8gh

## What is CVE-2020-15262?

CVE-2020-15262 is a low-severity vulnerability in waysact webpack-subresource-integrity, published on 19 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In webpack-subresource-integrity before version 1.5.1, all dynamically loaded chunks receive an invalid integrity hash that is ignored by the browser, and therefore the browser cannot validate their integrity. This removes the additional level of protection offered by SRI for such chunks. Top-level chunks are unaffected. This issue is patched in version 1.5.1.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2020-15262?

2 open source packages ship an affected version, including webpack-subresource-integrity. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `webpack-subresource-integrity` | npm | All versions | 1.5.1 |
| `webpack-subresource-integrity` | npm | All versions | 1.5.1 |

Products: Webpack-Subresource-Integrity Project Webpack-Subresource-Integrity.

## How do I fix CVE-2020-15262?

Upgrade webpack-subresource-integrity to 1.5.1 or later.

## Is CVE-2020-15262 being exploited?

There is no known exploitation of CVE-2020-15262 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15262 and fix it if it is affected.

What it is: CVE-2020-15262 is a low-severity vulnerability in waysact webpack-subresource-integrity, published on 19 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15262 in the wild and no public exploit code.

Affected packages and fixed versions:
- webpack-subresource-integrity (npm): affected all versions; fixed in 1.5.1
- webpack-subresource-integrity (npm): affected all versions; fixed in 1.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15262/ (Markdown: https://insights.sbomify.com/CVE-2020-15262/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15262
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15262
- OSV: https://osv.dev/vulnerability/CVE-2020-15262

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15262/
Summaries are generated and may contain mistakes; the official description above is the record.
