CVE-2020-15263 XSS in platform

High 8.0 Published Updated

Attackers can execute arbitrary scripts in user browsers due to improper escaping of inline attributes in the Orchid Platform web application.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-15263?

CVE-2020-15263 is a high-severity cross-site scripting vulnerability in orchidsoftware platform, published on 19 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In platform before version 9.4.4, inline attributes are not properly escaped. If the data that came from users was not escaped, then an XSS vulnerability is possible. The issue was introduced in 9.0.0 and fixed in 9.4.4.

Weakness: CWE-79

Which versions are affected by CVE-2020-15263?

2 open source packages ship an affected version, including orchid/platform. It affects 1 product.

PackageAffectedFixed in
orchid/platform PackagistFrom 9.0.09.4.4
orchid/platform PackagistFrom 9.0.09.4.4

Products include Orchid Platform.

How do I fix CVE-2020-15263?

Upgrade orchid/platform to 9.4.4 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-15263 being exploited?

There is no known exploitation of CVE-2020-15263 in the wild and no public exploit code.

Sources

Also known as GHSA-589w-hccm-265x.

Is CVE-2020-15263 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free