# CVE-2020-15263: XSS in platform

> Attackers can execute arbitrary scripts in user browsers due to improper escaping of inline attributes in the Orchid Platform web application.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-589w-hccm-265x

## What is CVE-2020-15263?

CVE-2020-15263 is a high-severity cross-site scripting vulnerability in orchidsoftware platform, published on 19 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In platform before version 9.4.4, inline attributes are not properly escaped. If the data that came from users was not escaped, then an XSS vulnerability is possible. The issue was introduced in 9.0.0 and fixed in 9.4.4.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-15263?

2 open source packages ship an affected version, including orchid/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `orchid/platform` | Packagist | From 9.0.0 | 9.4.4 |
| `orchid/platform` | Packagist | From 9.0.0 | 9.4.4 |

Products: Orchid Platform.

## How do I fix CVE-2020-15263?

Upgrade orchid/platform to 9.4.4 or later.

## Is CVE-2020-15263 being exploited?

There is no known exploitation of CVE-2020-15263 in the wild and no public exploit code.

## Other vulnerabilities in orchidsoftware platform

- [CVE-2023-36825](https://insights.sbomify.com/CVE-2023-36825/): Orchid Deserialization of Untrusted Data vulnerability leads to Remote Code Execution (critical 9.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15263 and fix it if it is affected.

What it is: CVE-2020-15263 is a high-severity cross-site scripting vulnerability in orchidsoftware platform, published on 19 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15263 in the wild and no public exploit code.

Affected packages and fixed versions:
- orchid/platform (Packagist): affected from 9.0.0; fixed in 9.4.4
- orchid/platform (Packagist): affected from 9.0.0; fixed in 9.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15263/ (Markdown: https://insights.sbomify.com/CVE-2020-15263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15263
- OSV: https://osv.dev/vulnerability/CVE-2020-15263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15263/
Summaries are generated and may contain mistakes; the official description above is the record.
