# CVE-2020-15264: Privilege Escalation in Boxstarter

> Unprivileged users can escalate to SYSTEM privileges by placing a malicious DLL in a writable directory added to the system PATH by the Boxstarter installer.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rpgx-h675-r3jf

## What is CVE-2020-15264?

CVE-2020-15264 is a high-severity vulnerability in chocolatey boxstarter, published on 20 Oct 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Boxstarter installer before version 2.13.0 configures C:\ProgramData\Boxstarter to be in the system-wide PATH environment variable. However, this directory is writable by normal, unprivileged users. To exploit the vulnerability, place a DLL in this directory that a privileged service is looking for. For example, WptsExtensions.dll When Windows starts, it'll execute the code in DllMain() with SYSTEM privileges. Any unprivileged user can execute code with SYSTEM privileges. The issue is fixed in version 3.13.0

Weakness: CWE-73 (External Control of File Name or Path), CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2020-15264?

It affects 1 product.


Products: Chocolatey Boxstarter.

## How do I fix CVE-2020-15264?

No fix has been published for CVE-2020-15264 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-15264 being exploited?

There is no known exploitation of CVE-2020-15264 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15264 and fix it if it is affected.

What it is: CVE-2020-15264 is a high-severity vulnerability in chocolatey boxstarter, published on 20 Oct 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15264 in the wild and no public exploit code.

Affected product: chocolatey boxstarter. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15264/ (Markdown: https://insights.sbomify.com/CVE-2020-15264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15264
- OSV: https://osv.dev/vulnerability/CVE-2020-15264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15264/
Summaries are generated and may contain mistakes; the official description above is the record.
