# CVE-2020-15265: Segfault in Tensorflow

> An attacker can cause a segmentation fault and denial of service in TensorFlow by passing an invalid axis value to the quantization function.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-tensorflow-2020-15265, GHSA-rrfp-j2mp-hq9c, PYSEC-2020-138, PYSEC-2020-295, PYSEC-2020-330

## What is CVE-2020-15265?

CVE-2020-15265 is a medium-severity memory corruption vulnerability in Google Tensorflow, published on 21 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Tensorflow before version 2.4.0, an attacker can pass an invalid `axis` value to `tf.quantization.quantize_and_dequantize`. This results in accessing a dimension outside the rank of the input tensor in the C++ kernel implementation. However, dim_size only does a DCHECK to validate the argument and then uses it to access the corresponding element of an array. Since in normal builds, `DCHECK`-like macros are no-ops, this results in segfault and access out of bounds of the array. The issue is patched in eccb7ec454e6617738554a255d77f08e60ee0808 and TensorFlow 2.4.0 will be released containing the patch. TensorFlow nightly packages after this commit will also have the issue resolved.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2020-15265?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | Bitnami | All versions | 2.4.0 |
| `tensorflow` | PyPI | All versions | 2.4.0 |
| `tensorflow` | PyPI | All versions | 2.4.0 |
| `tensorflow` | PyPI | All versions | 2.4.0 |
| `tensorflow-cpu` | PyPI | All versions | 2.4.0 |
| `tensorflow-cpu` | PyPI | All versions | 2.4.0 |
| `tensorflow-cpu` | PyPI | All versions | 2.4.0 |
| `tensorflow-gpu` | PyPI | All versions | 2.4.0 |
| `tensorflow-gpu` | PyPI | All versions | 2.4.0 |
| `tensorflow-gpu` | PyPI | All versions | 2.4.0 |

Products: Google Tensorflow.

## How do I fix CVE-2020-15265?

Upgrade tensorflow to 2.4.0 or later.

## Is CVE-2020-15265 being exploited?

There is no known exploitation of CVE-2020-15265 in the wild and no public exploit code.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15265 and fix it if it is affected.

What it is: CVE-2020-15265 is a medium-severity memory corruption vulnerability in Google Tensorflow, published on 21 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15265 in the wild and no public exploit code.

Affected packages and fixed versions:
- tensorflow (Bitnami): affected all versions; fixed in 2.4.0
- tensorflow (PyPI): affected all versions; fixed in 2.4.0
- tensorflow (PyPI): affected all versions; fixed in 2.4.0
- tensorflow (PyPI): affected all versions; fixed in 2.4.0
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.4.0
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.4.0
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.4.0
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.4.0
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.4.0
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15265/ (Markdown: https://insights.sbomify.com/CVE-2020-15265/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15265
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15265
- OSV: https://osv.dev/vulnerability/CVE-2020-15265

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15265/
Summaries are generated and may contain mistakes; the official description above is the record.
