# CVE-2020-15266: Undefined behavior in Tensorflow

> An attacker can cause a segmentation fault and crash the application by providing large box values to the crop_and_resize function in TensorFlow.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-tensorflow-2020-15266, GHSA-xwhf-g6j5-j5gc, PYSEC-2020-139, PYSEC-2020-296, PYSEC-2020-331

## What is CVE-2020-15266?

CVE-2020-15266 is a low-severity denial of service vulnerability in Google Tensorflow, published on 21 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Tensorflow before version 2.4.0, when the `boxes` argument of `tf.image.crop_and_resize` has a very large value, the CPU kernel implementation receives it as a C++ `nan` floating point value. Attempting to operate on this is undefined behavior which later produces a segmentation fault. The issue is patched in eccb7ec454e6617738554a255d77f08e60ee0808 and TensorFlow 2.4.0 will be released containing the patch. TensorFlow nightly packages after this commit will also have the issue resolved.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2020-15266?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | Bitnami | All versions | 2.4.0 |
| `tensorflow` | PyPI | All versions | 2.4.0 |
| `tensorflow` | PyPI | All versions | 2.4.0 |
| `tensorflow` | PyPI | All versions | 2.4.0 |
| `tensorflow-cpu` | PyPI | All versions | 2.4.0 |
| `tensorflow-cpu` | PyPI | All versions | 2.4.0 |
| `tensorflow-cpu` | PyPI | All versions | 2.4.0 |
| `tensorflow-gpu` | PyPI | All versions | 2.4.0 |
| `tensorflow-gpu` | PyPI | All versions | 2.4.0 |
| `tensorflow-gpu` | PyPI | All versions | 2.4.0 |

Products: Google Tensorflow.

## How do I fix CVE-2020-15266?

Upgrade tensorflow to 2.4.0 or later.

## Is CVE-2020-15266 being exploited?

There is no known exploitation of CVE-2020-15266 in the wild and no public exploit code.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15266 and fix it if it is affected.

What it is: CVE-2020-15266 is a low-severity denial of service vulnerability in Google Tensorflow, published on 21 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15266 in the wild and no public exploit code.

Affected packages and fixed versions:
- tensorflow (Bitnami): affected all versions; fixed in 2.4.0
- tensorflow (PyPI): affected all versions; fixed in 2.4.0
- tensorflow (PyPI): affected all versions; fixed in 2.4.0
- tensorflow (PyPI): affected all versions; fixed in 2.4.0
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.4.0
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.4.0
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.4.0
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.4.0
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.4.0
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15266/ (Markdown: https://insights.sbomify.com/CVE-2020-15266/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15266
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15266
- OSV: https://osv.dev/vulnerability/CVE-2020-15266

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15266/
Summaries are generated and may contain mistakes; the official description above is the record.
