{"answers":{"affected":"6 open source packages ship an affected version, including spree. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15269 in the wild and no public exploit code.","fix":"Upgrade spree to a fixed version for your release line: 3.7.11, 4.0.4 or 4.1.11.","what":"CVE-2020-15269 is a high-severity authentication bypass vulnerability in spree, published on 20 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-15269 and fix it if it is affected.\n\nWhat it is: CVE-2020-15269 is a high-severity authentication bypass vulnerability in spree, published on 20 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-15269 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- spree (RubyGems): affected all versions; fixed in 3.7.11\n- spree (RubyGems): affected all versions; fixed in 3.7.11\n- spree (RubyGems): affected from 4.0.0; fixed in 4.0.4\n- spree (RubyGems): affected from 4.0.0; fixed in 4.0.4\n- spree (RubyGems): affected from 4.1.0; fixed in 4.1.11\n- spree (RubyGems): affected from 4.1.0; fixed in 4.1.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15269/ (Markdown: https://insights.sbomify.com/CVE-2020-15269/index.md)","id":"CVE-2020-15269","markdown":"https://insights.sbomify.com/CVE-2020-15269/index.md","name":"CVE-2020-15269","record":{"aliases":["GHSA-f8cm-364f-q9qh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Spree e-commerce platform","requires_auth":"none","summary":"Attackers can reuse expired tokens to access Storefront API v2 endpoints, potentially reading or modifying data in Spree e-commerce applications.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"spree","vendor":"sparksolutions"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"In Spree before versions 3.7.11, 4.0.4, or 4.1.11, expired user tokens could be used to access Storefront API v2 endpoints. The issue is patched in versions 3.7.11, 4.0.4 and 4.1.11. A workaround without upgrading is described in the linked advisory.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Expired token reuse in Spree","id":"CVE-2020-15269","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"auth_bypass","year":"2020"},"n_packages":6,"n_references":2,"next":{"headline":"Improper session expiration in Parse Server","id":"CVE-2020-15270"},"packages":[{"ecosystem":"RubyGems","fixed":["3.7.11"],"introduced":["0"],"last_affected":[],"package":"spree","purl":null,"source":"GHSA-f8cm-364f-q9qh"},{"ecosystem":"RubyGems","fixed":["3.7.11"],"introduced":["0"],"last_affected":[],"package":"spree","purl":"pkg:gem/spree","source":"GHSA-f8cm-364f-q9qh"},{"ecosystem":"RubyGems","fixed":["4.0.4"],"introduced":["4.0.0"],"last_affected":[],"package":"spree","purl":null,"source":"GHSA-f8cm-364f-q9qh"},{"ecosystem":"RubyGems","fixed":["4.0.4"],"introduced":["4.0.0"],"last_affected":[],"package":"spree","purl":"pkg:gem/spree","source":"GHSA-f8cm-364f-q9qh"},{"ecosystem":"RubyGems","fixed":["4.1.11"],"introduced":["4.1.0"],"last_affected":[],"package":"spree","purl":null,"source":"GHSA-f8cm-364f-q9qh"},{"ecosystem":"RubyGems","fixed":["4.1.11"],"introduced":["4.1.0"],"last_affected":[],"package":"spree","purl":"pkg:gem/spree","source":"GHSA-f8cm-364f-q9qh"}],"prev":{"headline":"Undefined behavior in Tensorflow","id":"CVE-2020-15266"},"products":["spree"],"published":"2020-10-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["spree"]},"summary":"Attackers can reuse expired tokens to access Storefront API v2 endpoints, potentially reading or modifying data in Spree e-commerce applications.","url":"https://insights.sbomify.com/CVE-2020-15269/"}