{"answers":{"affected":"3 open source packages ship an affected version, including lookatme. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15271 in the wild and no public exploit code.","fix":"Upgrade lookatme to 2.3.0 or later.","what":"CVE-2020-15271 is a critical command injection vulnerability in d0c-s4vage lookatme, published on 26 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15271 and fix it if it is affected.\n\nWhat it is: CVE-2020-15271 is a critical command injection vulnerability in d0c-s4vage lookatme, published on 26 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15271 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- lookatme (PyPI): affected all versions; fixed in 2.3.0\n- lookatme (PyPI): affected all versions; fixed in 2.3.0\n- lookatme (PyPI): affected all versions; fixed in 2.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15271/ (Markdown: https://insights.sbomify.com/CVE-2020-15271/index.md)","id":"CVE-2020-15271","markdown":"https://insights.sbomify.com/CVE-2020-15271/index.md","name":"CVE-2020-15271","record":{"aliases":["DEBIAN-CVE-2020-15271","GHSA-c84h-w6cr-5v8q","PYSEC-2020-61"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python markdown renderer","requires_auth":"none","summary":"Attackers can execute arbitrary shell commands by tricking users into rendering malicious markdown with the lookatme library.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lookatme","vendor":"lookatme_project"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"In lookatme (python/pypi package) versions prior to 2.3.0, the package automatically loaded the built-in \"terminal\" and \"file_loader\" extensions. Users that use lookatme to render untrusted markdown may have malicious shell commands automatically run on their system. This is fixed in version 2.3.0. As a workaround, the `lookatme/contrib/terminal.py` and `lookatme/contrib/file_loader.py` files may be manually deleted. Additionally, it is always recommended to be aware of what is being rendered with lookatme.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Shell Command Execution in lookatme","id":"CVE-2020-15271","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2020"},"n_packages":3,"n_references":5,"next":{"headline":"Shell-injection in git-tag-annotation GitHub action","id":"CVE-2020-15272"},"packages":[{"ecosystem":"PyPI","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"lookatme","purl":null,"source":"GHSA-c84h-w6cr-5v8q"},{"ecosystem":"PyPI","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"lookatme","purl":"pkg:pypi/lookatme","source":"GHSA-c84h-w6cr-5v8q"},{"ecosystem":"PyPI","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"lookatme","purl":"pkg:pypi/lookatme","source":"PYSEC-2020-61"}],"prev":{"headline":"Improper session expiration in Parse Server","id":"CVE-2020-15270"},"products":["lookatme"],"published":"2020-10-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["d0c-s4vage"]},"summary":"Attackers can execute arbitrary shell commands by tricking users into rendering malicious markdown with the lookatme library.","url":"https://insights.sbomify.com/CVE-2020-15271/"}