# CVE-2020-15271: Shell Command Execution in lookatme

> Attackers can execute arbitrary shell commands by tricking users into rendering malicious markdown with the lookatme library.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-15271, GHSA-c84h-w6cr-5v8q, PYSEC-2020-61

## What is CVE-2020-15271?

CVE-2020-15271 is a critical command injection vulnerability in d0c-s4vage lookatme, published on 26 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In lookatme (python/pypi package) versions prior to 2.3.0, the package automatically loaded the built-in "terminal" and "file_loader" extensions. Users that use lookatme to render untrusted markdown may have malicious shell commands automatically run on their system. This is fixed in version 2.3.0. As a workaround, the `lookatme/contrib/terminal.py` and `lookatme/contrib/file_loader.py` files may be manually deleted. Additionally, it is always recommended to be aware of what is being rendered with lookatme.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-15271?

3 open source packages ship an affected version, including lookatme. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lookatme` | PyPI | All versions | 2.3.0 |
| `lookatme` | PyPI | All versions | 2.3.0 |
| `lookatme` | PyPI | All versions | 2.3.0 |

Products: Lookatme Project Lookatme.

## How do I fix CVE-2020-15271?

Upgrade lookatme to 2.3.0 or later.

## Is CVE-2020-15271 being exploited?

There is no known exploitation of CVE-2020-15271 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15271 and fix it if it is affected.

What it is: CVE-2020-15271 is a critical command injection vulnerability in d0c-s4vage lookatme, published on 26 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15271 in the wild and no public exploit code.

Affected packages and fixed versions:
- lookatme (PyPI): affected all versions; fixed in 2.3.0
- lookatme (PyPI): affected all versions; fixed in 2.3.0
- lookatme (PyPI): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15271/ (Markdown: https://insights.sbomify.com/CVE-2020-15271/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15271
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15271
- OSV: https://osv.dev/vulnerability/CVE-2020-15271

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15271/
Summaries are generated and may contain mistakes; the official description above is the record.
