# CVE-2020-15391: DevSpace vulnerable to remote code execution

> DevSpace UI lacks WebSocket authentication, allowing attackers to execute remote code on pods via CSRF-like attacks.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6h8c-gw33-cjm2

## What is CVE-2020-15391?

CVE-2020-15391 is a critical missing authorization vulnerability in n/a, published on 23 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The UI in DevSpace 4.13.0 allows web sites to execute actions on pods (on behalf of a victim) because of a lack of authentication for the WebSocket protocol. This leads to remote code execution.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2020-15391?

2 open source packages ship an affected version, including github.com/loft-sh/devspace. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/loft-sh/devspace` | Go | All versions | 4.14.0 |
| `github.com/loft-sh/devspace` | Go | All versions | 4.14.0 |

Products: Devspace Devspace.

## How do I fix CVE-2020-15391?

Upgrade github.com/loft-sh/devspace to 4.14.0 or later.

## Is CVE-2020-15391 being exploited?

There is no known exploitation of CVE-2020-15391 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-42283](https://insights.sbomify.com/CVE-2026-42283/): DevSpace UI Server WebSocket CheckOrigin does not validate source (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15391 and fix it if it is affected.

What it is: CVE-2020-15391 is a critical missing authorization vulnerability in n/a, published on 23 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15391 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/loft-sh/devspace (Go): affected all versions; fixed in 4.14.0
- github.com/loft-sh/devspace (Go): affected all versions; fixed in 4.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15391/ (Markdown: https://insights.sbomify.com/CVE-2020-15391/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15391
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15391
- OSV: https://osv.dev/vulnerability/CVE-2020-15391

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15391/
Summaries are generated and may contain mistakes; the official description above is the record.
