CVE-2020-15400 Cross-Site Request Forgery in CakePHP
Attackers can bypass CSRF protections in CakePHP, potentially enabling cross-site request forgery attacks when combined with XSS.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-15400?
CVE-2020-15400 is a medium-severity vulnerability in n/a, published on 30 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
CakePHP before 4.0.6 mishandles CSRF token generation. This might be remotely exploitable in conjunction with XSS.
Which versions are affected by CVE-2020-15400?
4 open source packages ship an affected version, including cakephp/cakephp. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cakephp/cakephp Packagist | All versions | 3.10.3 |
cakephp/cakephp Packagist | All versions | 3.10.3 |
cakephp/cakephp Packagist | From 4.0.0 | 4.0.6 |
cakephp/cakephp Packagist | From 4.0.0 | 4.0.6 |
Products include Cakefoundation Cakephp.
How do I fix CVE-2020-15400?
Upgrade cakephp/cakephp to a fixed version for your release line: 3.10.3 or 4.0.6.
Is CVE-2020-15400 being exploited?
There is no known exploitation of CVE-2020-15400 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2020-15400, GHSA-j33j-fg2g-mcv2, UBUNTU-CVE-2020-15400.