{"answers":{"affected":"4 open source packages ship an affected version, including cakephp/cakephp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15400 in the wild and no public exploit code.","fix":"Upgrade cakephp/cakephp to a fixed version for your release line: 3.10.3 or 4.0.6.","what":"CVE-2020-15400 is a medium-severity vulnerability in n/a, published on 30 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15400 and fix it if it is affected.\n\nWhat it is: CVE-2020-15400 is a medium-severity vulnerability in n/a, published on 30 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15400 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cakephp/cakephp (Packagist): affected all versions; fixed in 3.10.3\n- cakephp/cakephp (Packagist): affected all versions; fixed in 3.10.3\n- cakephp/cakephp (Packagist): affected from 4.0.0; fixed in 4.0.6\n- cakephp/cakephp (Packagist): affected from 4.0.0; fixed in 4.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15400/ (Markdown: https://insights.sbomify.com/CVE-2020-15400/index.md)","id":"CVE-2020-15400","markdown":"https://insights.sbomify.com/CVE-2020-15400/index.md","name":"CVE-2020-15400","record":{"aliases":["DEBIAN-CVE-2020-15400","GHSA-j33j-fg2g-mcv2","UBUNTU-CVE-2020-15400"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"CakePHP framework","requires_auth":"none","summary":"Attackers can bypass CSRF protections in CakePHP, potentially enabling cross-site request forgery attacks when combined with XSS.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cakephp","vendor":"cakefoundation"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"CakePHP before 4.0.6 mishandles CSRF token generation. This might be remotely exploitable in conjunction with XSS.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Request Forgery in CakePHP","id":"CVE-2020-15400","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"csrf","year":"2020"},"n_packages":4,"n_references":1,"next":{"headline":"Path traversal in n/a","id":"CVE-2020-15401"},"packages":[{"ecosystem":"Packagist","fixed":["3.10.3"],"introduced":["0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-j33j-fg2g-mcv2"},{"ecosystem":"Packagist","fixed":["3.10.3"],"introduced":["0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-j33j-fg2g-mcv2"},{"ecosystem":"Packagist","fixed":["4.0.6"],"introduced":["4.0.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-j33j-fg2g-mcv2"},{"ecosystem":"Packagist","fixed":["4.0.6"],"introduced":["4.0.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-j33j-fg2g-mcv2"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2020-15397"},"products":["n/a"],"published":"2020-06-30","related":[{"cvss_score":7.5,"headline":"CakePHPallows remote attackers to read arbitrary files via XML data containing external entity references","id":"CVE-2012-4399","kev_date_added":null,"published":"2012-10-09"},{"cvss_score":7.5,"headline":"CakePHP allows remote attackers to modify internal Cake cache and execute arbitrary code","id":"CVE-2010-4335","kev_date_added":null,"published":"2011-01-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can bypass CSRF protections in CakePHP, potentially enabling cross-site request forgery attacks when combined with XSS.","url":"https://insights.sbomify.com/CVE-2020-15400/"}