# CVE-2020-15513: Incorrect access control in typo3_forum

> An attacker can bypass access controls in the TYPO3 forum extension to perform unauthorized actions.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-57gr-jvqr-3hwm

## What is CVE-2020-15513?

CVE-2020-15513 is a medium-severity missing authorization vulnerability in n/a, published on 7 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The typo3_forum extension before 1.2.1 for TYPO3 has Incorrect Access Control.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-15513?

2 open source packages ship an affected version, including mittwald/typo3_forum. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mittwald/typo3_forum` | Packagist | All versions | 1.2.1 |
| `mittwald/typo3_forum` | Packagist | All versions | 1.2.1 |

Products: Mittwald Typo3 Forum.

## How do I fix CVE-2020-15513?

Upgrade mittwald/typo3_forum to 1.2.1 or later.

## Is CVE-2020-15513 being exploited?

There is no known exploitation of CVE-2020-15513 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15513 and fix it if it is affected.

What it is: CVE-2020-15513 is a medium-severity missing authorization vulnerability in n/a, published on 7 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15513 in the wild and no public exploit code.

Affected packages and fixed versions:
- mittwald/typo3_forum (Packagist): affected all versions; fixed in 1.2.1
- mittwald/typo3_forum (Packagist): affected all versions; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15513/ (Markdown: https://insights.sbomify.com/CVE-2020-15513/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15513
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15513
- OSV: https://osv.dev/vulnerability/CVE-2020-15513

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15513/
Summaries are generated and may contain mistakes; the official description above is the record.
