CVE-2020-15514 jh_captcha for Typo3 XSS Vulnerability
Cross-site scripting vulnerability in the jh_captcha extension for TYPO3 allows attackers to inject malicious scripts into web pages viewed by other users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-15514?
CVE-2020-15514 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The jh_captcha extension through 2.1.3, and 3.x through 3.0.2, for TYPO3 allows XSS.
Weakness: CWE-79
Which versions are affected by CVE-2020-15514?
4 open source packages ship an affected version, including haffner/jh_captcha. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
haffner/jh_captcha Packagist | All versions | 2.1.4 |
haffner/jh_captcha Packagist | All versions | 2.1.4 |
haffner/jh_captcha Packagist | From 3.0.0 | 3.0.3 |
haffner/jh_captcha Packagist | From 3.0.0 | 3.0.3 |
Products include Jh Captcha Project Jh Captcha.
How do I fix CVE-2020-15514?
Upgrade haffner/jh_captcha to a fixed version for your release line: 2.1.4 or 3.0.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-15514 being exploited?
There is no known exploitation of CVE-2020-15514 in the wild and no public exploit code.
Sources
Also known as GHSA-23fm-v895-3qxq.