# CVE-2020-15515: Remote code execution in turn extension for TYPO3

> Attackers can execute arbitrary code remotely via the TYPO3 turn extension, requiring immediate upgrade to a patched version.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-q7j5-9j77-g4gq

## What is CVE-2020-15515?

CVE-2020-15515 is a high-severity code injection vulnerability in n/a, published on 7 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The turn extension through 0.3.2 for TYPO3 allows Remote Code Execution.

## Which versions are affected by CVE-2020-15515?

2 open source packages ship an affected version, including marcwillmann/turn. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `marcwillmann/turn` | Packagist | All versions | 0.3.3 |
| `marcwillmann/turn` | Packagist | All versions | 0.3.3 |

Products: Turn\! Project Turn\!.

## How do I fix CVE-2020-15515?

Upgrade marcwillmann/turn to 0.3.3 or later.

## Is CVE-2020-15515 being exploited?

There is no known exploitation of CVE-2020-15515 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15515 and fix it if it is affected.

What it is: CVE-2020-15515 is a high-severity code injection vulnerability in n/a, published on 7 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15515 in the wild and no public exploit code.

Affected packages and fixed versions:
- marcwillmann/turn (Packagist): affected all versions; fixed in 0.3.3
- marcwillmann/turn (Packagist): affected all versions; fixed in 0.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15515/ (Markdown: https://insights.sbomify.com/CVE-2020-15515/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15515
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15515
- OSV: https://osv.dev/vulnerability/CVE-2020-15515

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15515/
Summaries are generated and may contain mistakes; the official description above is the record.
