CVE-2020-15517 ke_search for Typo3 XSS Vulnerability
Cross-site scripting vulnerability in the ke_search extension for TYPO3 allows attackers to inject malicious scripts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-15517?
CVE-2020-15517 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The ke_search (aka Faceted Search) extension through 2.8.2, and 3.x through 3.1.3, for TYPO3 allows XSS.
Weakness: CWE-79
Which versions are affected by CVE-2020-15517?
4 open source packages ship an affected version, including tpwd/ke_search. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tpwd/ke_search Packagist | All versions | 2.8.3 |
tpwd/ke_search Packagist | All versions | 2.8.3 |
tpwd/ke_search Packagist | From 3.0.0 | 3.1.4 |
tpwd/ke_search Packagist | From 3.0.0 | 3.1.4 |
Products include Faceted Search Project Faceted Search.
How do I fix CVE-2020-15517?
Upgrade tpwd/ke_search to a fixed version for your release line: 2.8.3 or 3.1.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-15517 being exploited?
There is no known exploitation of CVE-2020-15517 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-gg48-mpp8-cgqc.