{"answers":{"affected":"4 open source packages ship an affected version, including tpwd/ke_search. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15517 in the wild and no public exploit code.","fix":"Upgrade tpwd/ke_search to a fixed version for your release line: 2.8.3 or 3.1.4.","what":"CVE-2020-15517 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15517 and fix it if it is affected.\n\nWhat it is: CVE-2020-15517 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15517 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tpwd/ke_search (Packagist): affected all versions; fixed in 2.8.3\n- tpwd/ke_search (Packagist): affected all versions; fixed in 2.8.3\n- tpwd/ke_search (Packagist): affected from 3.0.0; fixed in 3.1.4\n- tpwd/ke_search (Packagist): affected from 3.0.0; fixed in 3.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15517/ (Markdown: https://insights.sbomify.com/CVE-2020-15517/index.md)","id":"CVE-2020-15517","markdown":"https://insights.sbomify.com/CVE-2020-15517/index.md","name":"CVE-2020-15517","record":{"aliases":["GHSA-gg48-mpp8-cgqc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"TYPO3 extension","requires_auth":"low_privilege","summary":"Cross-site scripting vulnerability in the ke_search extension for TYPO3 allows attackers to inject malicious scripts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"faceted_search","vendor":"faceted_search_project"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The ke_search (aka Faceted Search) extension through 2.8.2, and 3.x through 3.1.3, for TYPO3 allows XSS.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ke_search for Typo3 XSS Vulnerability","id":"CVE-2020-15517","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":4,"n_references":2,"next":{"headline":"Missing authorization in n/a","id":"CVE-2020-15518"},"packages":[{"ecosystem":"Packagist","fixed":["2.8.3"],"introduced":["0"],"last_affected":[],"package":"tpwd/ke_search","purl":null,"source":"GHSA-gg48-mpp8-cgqc"},{"ecosystem":"Packagist","fixed":["2.8.3"],"introduced":["0"],"last_affected":[],"package":"tpwd/ke_search","purl":"pkg:composer/tpwd/ke_search","source":"GHSA-gg48-mpp8-cgqc"},{"ecosystem":"Packagist","fixed":["3.1.4"],"introduced":["3.0.0"],"last_affected":[],"package":"tpwd/ke_search","purl":null,"source":"GHSA-gg48-mpp8-cgqc"},{"ecosystem":"Packagist","fixed":["3.1.4"],"introduced":["3.0.0"],"last_affected":[],"package":"tpwd/ke_search","purl":"pkg:composer/tpwd/ke_search","source":"GHSA-gg48-mpp8-cgqc"}],"prev":{"headline":"Cross-Site Request Forgery in mm_forum","id":"CVE-2020-15516"},"products":["n/a"],"published":"2020-07-07","related":[{"cvss_score":6.3,"headline":"ke_search (aka Faceted Search) vulnerable to Cross-Site Scripting","id":"CVE-2023-35783","kev_date_added":null,"published":"2023-06-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in the ke_search extension for TYPO3 allows attackers to inject malicious scripts.","url":"https://insights.sbomify.com/CVE-2020-15517/"}