# CVE-2020-15517: ke_search for Typo3 XSS Vulnerability

> Cross-site scripting vulnerability in the ke_search extension for TYPO3 allows attackers to inject malicious scripts.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gg48-mpp8-cgqc

## What is CVE-2020-15517?

CVE-2020-15517 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The ke_search (aka Faceted Search) extension through 2.8.2, and 3.x through 3.1.3, for TYPO3 allows XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-15517?

4 open source packages ship an affected version, including tpwd/ke_search. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tpwd/ke_search` | Packagist | All versions | 2.8.3 |
| `tpwd/ke_search` | Packagist | All versions | 2.8.3 |
| `tpwd/ke_search` | Packagist | From 3.0.0 | 3.1.4 |
| `tpwd/ke_search` | Packagist | From 3.0.0 | 3.1.4 |

Products: Faceted Search Project Faceted Search.

## How do I fix CVE-2020-15517?

Upgrade tpwd/ke_search to a fixed version for your release line: 2.8.3 or 3.1.4.

## Is CVE-2020-15517 being exploited?

There is no known exploitation of CVE-2020-15517 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-35783](https://insights.sbomify.com/CVE-2023-35783/): ke_search (aka Faceted Search) vulnerable to Cross-Site Scripting (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15517 and fix it if it is affected.

What it is: CVE-2020-15517 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15517 in the wild and no public exploit code.

Affected packages and fixed versions:
- tpwd/ke_search (Packagist): affected all versions; fixed in 2.8.3
- tpwd/ke_search (Packagist): affected all versions; fixed in 2.8.3
- tpwd/ke_search (Packagist): affected from 3.0.0; fixed in 3.1.4
- tpwd/ke_search (Packagist): affected from 3.0.0; fixed in 3.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15517/ (Markdown: https://insights.sbomify.com/CVE-2020-15517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15517
- OSV: https://osv.dev/vulnerability/CVE-2020-15517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15517/
Summaries are generated and may contain mistakes; the official description above is the record.
