# CVE-2020-15523: Path traversal in n/a

> Attackers can execute arbitrary code via a Trojan horse DLL when CPython is embedded in native Windows applications using Py_SetPath.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jul 2020
- **Updated:** 14 Oct 2026
- **Also known as:** BIT-libpython-2020-15523, BIT-python-2020-15523, BIT-python-min-2020-15523, GHSA-mj5j-j2qm-c8g4, PSF-2020-4

## What is CVE-2020-15523?

CVE-2020-15523 is a high-severity path traversal vulnerability in Netapp Snapcenter, published on 4 Jul 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In Python 3.6 through 3.6.10, 3.7 through 3.7.8, 3.8 through 3.8.4rc1, and 3.9 through 3.9.0b4 on Windows, a Trojan horse python3.dll might be used in cases where CPython is embedded in a native application. This occurs because python3X.dll may use an invalid search path for python3.dll loading (after Py_SetPath has been used). NOTE: this issue CANNOT occur when using python.exe from a standard (non-embedded) Python installation on Windows.

Weakness: CWE-908 (Use of Uninitialized Resource), CWE-427 (Uncontrolled Search Path Element)

## Which versions are affected by CVE-2020-15523?

3 open source packages ship an affected version, including libpython, python and python-min. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpython` | Bitnami | From 3.5.0 | 3.5.10, 3.6.12, 3.7.9, 3.8.4 |
| `python` | Bitnami | From 3.5.0 | 3.5.10, 3.6.12, 3.7.9, 3.8.4 |
| `python-min` | Bitnami | From 3.5.0 | 3.5.10, 3.6.12, 3.7.9, 3.8.4 |

Products: Netapp Snapcenter, Python Python.

## How do I fix CVE-2020-15523?

Upgrade libpython to a fixed version for your release line: 3.5.10, 3.6.12, 3.7.9 or 3.8.4.

## Is CVE-2020-15523 being exploited?

There is no known exploitation of CVE-2020-15523 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Snapcenter

- [CVE-2025-26512](https://insights.sbomify.com/CVE-2025-26512/): CVE-2025-26512 Privilege Escalation Vulnerability in SnapCenter (critical 9.9)
- [CVE-2023-1096](https://insights.sbomify.com/CVE-2023-1096/): Auth bypass in SnapCenter (critical 9.8)
- [CVE-2023-27316](https://insights.sbomify.com/CVE-2023-27316/): Privilege Escalation Vulnerability in SnapCenter (high 8.8)
- [CVE-2023-27313](https://insights.sbomify.com/CVE-2023-27313/): Privilege Escalation Vulnerability in SnapCenter (high 8.3)
- [CVE-2022-38732](https://insights.sbomify.com/CVE-2022-38732/): Security feature bypass in SnapCenter (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15523 and fix it if it is affected.

What it is: CVE-2020-15523 is a high-severity path traversal vulnerability in Netapp Snapcenter, published on 4 Jul 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15523 in the wild and no public exploit code.

Affected packages and fixed versions:
- libpython (Bitnami): affected from 3.5.0; fixed in 3.5.10, 3.6.12, 3.7.9, 3.8.4
- python (Bitnami): affected from 3.5.0; fixed in 3.5.10, 3.6.12, 3.7.9, 3.8.4
- python-min (Bitnami): affected from 3.5.0; fixed in 3.5.10, 3.6.12, 3.7.9, 3.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15523/ (Markdown: https://insights.sbomify.com/CVE-2020-15523/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15523
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15523
- OSV: https://osv.dev/vulnerability/CVE-2020-15523

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15523/
Summaries are generated and may contain mistakes; the official description above is the record.
