CVE-2020-15562 Cross-site scripting in n/a
Attackers can execute arbitrary JavaScript in victim browsers via crafted HTML emails, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-15562?
CVE-2020-15562 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 6 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in Roundcube Webmail before 1.2.11, 1.3.x before 1.3.14, and 1.4.x before 1.4.7. It allows XSS via a crafted HTML e-mail message, as demonstrated by a JavaScript payload in the xmlns (aka XML namespace) attribute of a HEAD element when an SVG element exists.
Weakness: CWE-79
Which versions are affected by CVE-2020-15562?
1 open source package ship an affected version, including roundcube. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
roundcube Bitnami | All versions | 1.2.11, 1.3.14, 1.4.7 |
Products include Debian Debian Linux, Roundcube Webmail.
How do I fix CVE-2020-15562?
Upgrade roundcube to a fixed version for your release line: 1.2.11, 1.3.14 or 1.4.7.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-15562 being exploited?
There is no known exploitation of CVE-2020-15562 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-roundcube-2020-15562, DEBIAN-CVE-2020-15562, DSA-4720-1, GHSA-7grq-wwvx-8jcv, UBUNTU-CVE-2020-15562.